Bug 976833 - Update 1.7.0.25.-2.3.10.3 makes Seamonkey and Firefox to lock up
Update 1.7.0.25.-2.3.10.3 makes Seamonkey and Firefox to lock up
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: java-1.7.0-openjdk (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andrew Azores
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 11:11 EDT by Knudch
Modified: 2013-10-17 13:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 11:33:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Plugin Debug log for browserspy.dk/java.php (19.28 KB, text/plain)
2013-07-09 16:36 EDT, Andrew Azores
no flags Details

  None (edit)
Description Knudch 2013-06-21 11:11:11 EDT
Description of problem:
After update applied on 20/6-2013 Accessing WEB sites with java content browser sleeps forever, can maybe extreem slowly

Version-Release number of selected component (if applicable):
Seamonkey 2.17.1
Firefox 21.0

Previous java version
1.7.0.19-2.3.9.6.fc17.i686

How reproducible:
Access this URL fx.http://browserspy.dk/java.php

Steps to Reproduce:
1.install update 1.7.0.25-2.3.10.3.fc17.i686
2.Check above link
3.

Actual results:
Browser locks up.

Expected results:
Showing Java information

Additional info:
Checked out on several other sites..same result, locks up, killed with System monitor
tried undo update and redo update...same result

As interim solution backdated to 1.7.0.3-2.1.fc17
No error after that

Knud
Comment 1 Knudch 2013-06-21 12:37:01 EDT
Browser plugin is Icedtea 1.7.0_b147-icedtea (22.0-b10)
Comment 2 Omair Majid 2013-06-21 12:43:16 EDT
Are you getting SELinux denials by any chance?
Comment 3 Knudch 2013-06-21 12:55:53 EDT
No SElinux is disabled
Comment 4 Omair Majid 2013-06-21 12:57:54 EDT
Anything in ~/.xsession-errors? Can you get the icedtea logs as described on [1] and attach them to this bug?

[1] http://icedtea.classpath.org/wiki/IcedTea-Web#Filing_bugs
Comment 5 Knudch 2013-06-21 13:40:10 EDT
No /.xsession-errors

Error happend also in Seamonkey 2.17.1 in a virtual vbox FC18 with
Icedtea 1.4
With or without the latest java update from 1.7.0.25-2.3.10.3.fc17.i686

I got Icedtea to generate the log in virtual machine

Seems to be Icedtea related as Openjdk 1.7.0.25-2.3.10.3.fc17 contains a Icedtea update
Comment 6 Knudch 2013-06-21 13:48:09 EDT
Actually it seems that Seamonkey is not locked up

After 5-6 min the Icedtea debug window pops up with a "serious exception has occurred..."
Applet not initialized.....
(Virtual FC18)
Comment 7 Knudch 2013-06-22 02:04:22 EDT
After updated Icedtea-web.i686 to 1.3.2-1.fc17 the Openjdk 1.7.0.25-2.3.10.3.fc17.i686 can be applied without problem

Secondary info: Problem still persist in FC18 with Icedtea 1.4.1 and latest Openjdk
Comment 8 jiri vanek 2013-06-23 11:47:23 EDT
As you probably noted, the IcedTea-Web had to be also updated after OpenJDK 1.7.0.25 update.
But seeing this: https://admin.fedoraproject.org/updates/FEDORA-2013-11291/icedtea-web-1.4-1.fc18 It should work.

You may try: reinstall icedtea-web, disable selinux, try other browser.

If other browser will work, then it will be different issue then update to OpebJDK 25. 

And will be arch specific - on x86_64 I'm pretty sure it is working.
Comment 9 Knudch 2013-06-24 16:44:34 EDT
Just for info:
Att: Jiri
You suggestion about reinstall ICEDTEA, disab SELinux, Other browser

None of these gives positive result

All tested under fc18 in a virtualbox FC18_i686, very clean system as just installed for test.

But this should be discussed under that Fedora version and not in this bugreport

I am using FC17 for daily work

Knud
Comment 10 jiri vanek 2013-07-01 07:25:01 EDT
This is deadlock caused by multiple applets with shared classloader. Assign to adam who rewrote this part of netx.

Strange is that it is reproducibel only on 32 arch.

Can 64b one start up so much more slowly?
Comment 11 Lukas Marek 2013-07-01 09:56:11 EDT
I'm having similar problem under Fedora 19. I don't know if it stopped working under F18 already (I've upgraded around week ago) as I'm not using icedtea-web daily.

icedtea-web-1.4-2.fc19.x86_64
java-1.7.0-openjdk-1.7.0.25-2.3.10.3.fc19.x86_64
SELinux disabled

testpage: http://www.javatester.org/version.html

Behaviour is similar as described earlier, however, I don't get any debug window in about 5 min.

Firefox output from terminal:

/builddir/build/BUILD/icedtea-web-1.4/plugin/icedteanp/IcedTeaNPPlugin.cc:483: thread 0x7f5eaf418b90: Error: Failed to create input pipe: Permission denied
java version "1.7.0_25"
OpenJDK Runtime Environment (fedora-2.3.10.3.fc19-x86_64)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)
Error: Unable to fetch applet instance id from Java side.
Error: Unable to fetch applet instance id from Java side.

If I create new profile, Firefox stays responsible, but the result is the same (except the "Error: Unable to fetch applet instance id from Java side." is not printed).
Comment 12 jiri vanek 2013-07-01 10:15:21 EDT
The javatester.org works for me pretty well on f19, 64b
for f19 there was an update of openjdk in meantime, but it should not matter.

 Error: Failed to create input pipe: Permission denied

Is very suspicious. 

So you have read write permissions on your temp directory? Are other applets  working? Cant be anything else blocking the pipe file?
Comment 13 Lukas Marek 2013-07-01 11:19:08 EDT
I had wrong permissions on "/var/tmp/icedteaplugin-*". I deleted all the files and it works... Sorry for the intrusion in this bug.
Comment 14 Fedora End Of Life 2013-07-03 15:19:11 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 15 Deepak Bhole 2013-07-03 15:29:41 EDT
Adam is on vacation for the next few weeks. Re-assigning to Andrew.
Comment 16 Knudch 2013-07-03 16:18:57 EDT
Should this bug not be closed ?

Problem does not exist under F17 any more (see my previous post) after update of ICEDtea.

However it persist in F18 in very similiar form, but that should be reported as a bug in F18

Knud
Comment 17 jiri vanek 2013-07-04 03:46:18 EDT
I have moved it under f18 - however I'm confused it started to work :)
Comment 18 Knudch 2013-07-04 14:50:40 EDT
Just to be clear:

Try this link in f18 (or F19)
with installed:
java-1.7.0.25-2.3.10.4.fc18
icedtea-web.686 1.4-1.fc18
(tested in vbox f18)

http://browserspy.dk/java.php

Either firefox or seamonkey

According to Ksysguard systemmonitor java process hook the CPU.
and browser went unresponsive

closing browser does'nt really kills the browser only possibel with Ksysguard (kill java and browser)

works perfect in f17 (real machine) with
java-1.7.0-openjdk.i686 1.7.0.25-2.3.10.3.fc17
icedtea-web.i686 1.3.2-1.fc17
Before latest update to Icedtea-web the java 1.7.0.25 update gave the same problem


Knud
Comment 19 Andrew Azores 2013-07-09 16:36:29 EDT
Created attachment 771228 [details]
Plugin Debug log for browserspy.dk/java.php
Comment 20 Andrew Azores 2013-07-09 16:50:06 EDT
$ rpm -qa | grep -e "icedtea\|openjdk"
java-1.7.0-openjdk-devel-1.7.0.25-2.3.10.4.fc18.x86_64
java-1.7.0-openjdk-javadoc-1.7.0.25-2.3.10.4.fc18.noarch
java-1.7.0-openjdk-src-1.7.0.25-2.3.10.4.fc18.x86_64
icedtea-web-1.4-1.fc18.x86_64
java-1.7.0-openjdk-1.7.0.25-2.3.10.4.fc18.x86_64

Can confirm behaviour on browserspy.dk/java.php with these package versions installed in an FC18 VM. Will investigate.
Comment 21 jiri vanek 2013-09-11 08:33:27 EDT
I think it is fixed in head of ITW (with latest Openjdk)
Comment 22 Andrew Azores 2013-09-11 09:47:49 EDT
Still seems to be locking for me (ITW head, F19 x86_64, latest OpenJDK).
Comment 23 Andrew Azores 2013-10-17 11:33:55 EDT
This issue has been resolved in IcedTea-Web upstream.

Note You need to log in before you can comment on or make changes to this bug.