Bug 976856 - Concurrency weight seems to not calculate properly
Concurrency weight seems to not calculate properly
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks: sat6-pulp-future
  Show dependency treegraph
 
Reported: 2013-06-21 12:20 EDT by Justin Sherrill
Modified: 2017-07-26 15:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 16:37:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2013-06-21 12:20:08 EDT
Description of problem:

It seems that pulp isn't obeying the concurrency weight properly.  Too many syncs run given the set concurrency and weight.


Version-Release number of selected component (if applicable):
2.1.2

How reproducible:
always 

Steps to Reproduce:
1.  Set concurrency_threshold to 5 in server.conf
2.  Set sync_weight to 2 in server.conf
3.  Restart httpd
4.  Initiate 4 syncs

Actual results:
Three of the syncs seem to run


Expected results:
Only 2 should run at any one time
Comment 1 Jason Connor 2013-09-18 16:37:56 EDT
I've been unable to reproduce this, but I didn't notice some behavior that seems confusing.

I followed the directions and started 4 syncs.
2 syncs kicked off immediately, and the other 2 waited.
The third sync started while the first was publishing.
This can give the impression that those two syncs are running concurrently, but the publish is actually a separate task from the sync in the dispatch system, even though they are grouped together (and their execution tracked together).

I'm going to close this bug. We can re-open if someone else is able to reproduce it.

Note You need to log in before you can comment on or make changes to this bug.