Bug 976896 - [RHSC] Server removed when moving to a different cluster
Summary: [RHSC] Server removed when moving to a different cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: 2.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Sahina Bose
QA Contact: Dustin Tsang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-21 19:44 UTC by Matt Mahoney
Modified: 2015-07-13 04:39 UTC (History)
7 users (show)

Fixed In Version: bb5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-23 22:25:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
bb4 - move server to a differnet cluster (4.32 MB, application/x-tar)
2013-06-21 19:47 UTC, Matt Mahoney
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 16027 0 None None None Never

Description Matt Mahoney 2013-06-21 19:44:55 UTC
Description of problem:
When moving a server from one cluster to another, an internal engine error occurred and the server was removed.

Version-Release number of selected component (if applicable):
bb4

How reproducible:


Steps to Reproduce:
1. Create cluster with 3+ servers.
2. Move all but one server to Maintenance
3. One at a time, move each server that is in maintenance to another cluster, using Server.Edit

Actual results:
Internal engine error. Server was then removed by the engine, when it should not have been removed

Expected results:


Additional info:

Comment 1 Matt Mahoney 2013-06-21 19:47:35 UTC
Created attachment 763949 [details]
bb4 - move server to a differnet cluster

Comment 3 Matt Mahoney 2013-06-21 20:08:43 UTC
Additional information, this happens when there are no servers that are in the cluster being moved to which are in up state.

Comment 4 Dustin Tsang 2013-07-08 17:57:45 UTC
verified in rhsc-bb5

Comment 5 Scott Haines 2013-09-23 22:25:50 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html


Note You need to log in before you can comment on or make changes to this bug.