Bug 976935 - mysqld.service is disactivated on upgrade from F18 to F19
mysqld.service is disactivated on upgrade from F18 to F19
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mariadb (Show other bugs)
19
All All
unspecified Severity high
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
RejectedFreezeException
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 20:17 EDT by Adam Williamson
Modified: 2013-06-29 14:43 EDT (History)
1 user (show)

See Also:
Fixed In Version: mariadb-5.5.31-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 14:43:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-06-21 20:17:44 EDT
I know there've been attempts to make sure this works, and I don't know yet why it doesn't, but just filing a bug quickly with the result of my test.

I did a minimal install of F18, did 'yum install mysql-server', 'yum update', 'systemctl enable mysqld.service', rebooted, ensured I could do 'mysql -u root' and 'systemctl status mysqld.service' returned enabled and active, and then did a fedup upgrade to F19. I got mariadb-server-5.5.31-1.fc19 to replace mysql-server, but on boot of the newly upgraded system, 'systemctl status mariadb-server.service' returns 'disabled', and 'mysql -u root' does not work.

Nominating as a freeze exception issue: if we can fix this for upgrades that don't use the update repos, it'd be nice.
Comment 1 Adam Williamson 2013-06-21 20:20:27 EDT
"'systemctl status mariadb-server.service' returns 'disabled'"

grr, I don't know why I typed that. I meant 'systemctl status mysqld.service' . The service file is present and the service works fine if enabled, but it is disabled after the upgrade.
Comment 2 Honza Horak 2013-06-24 03:30:02 EDT
An update mariadb-5.5.31-4.fc19 that should fix this issue is already in Bodhi. Can you verify it fixes the issue, Adam?

Since the build is already in testing, it means it should be 0-day update at worst. The question is -- do we need it to be in fedora 19 release repo?

If fedup uses updates repository, then 0-day update should work fine, right? It will only affect new installations from DVD without updates repository enabled, which actually doesn't matter, because this issue is valid only when upgrading.

So, I'm not sure if this really needs to be freeze exception. However, I'm not against it generally and I may also miss some scenario where we really need it.
Comment 3 Honza Horak 2013-06-24 04:09:44 EDT
Package mariadb-5.5.31-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mariadb-5.5.31-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10838/mariadb-5.5.31-4.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-06-24 04:11:18 EDT
mariadb-5.5.31-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-10838/mariadb-5.5.31-4.fc19
Comment 5 Adam Williamson 2013-06-24 11:30:06 EDT
Honza: fedup can at least theoretically do a media-based upgrade - it can use a DVD or DVD ISO as a source of packages. It is also possible that people may run an upgrade with the updates repo disabled if it proves to work around some other issue on upgrading. Neither is the end of the world, but it may be worth fixing.
Comment 6 Adam Williamson 2013-06-24 14:37:38 EDT
Discussed at 2013-06-24 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-24/f19final-blocker-review-8.2013-06-24-16.00.log.txt . This was rejected as a freeze exception issue: it was considered that it'd be pretty unlikely for a system with an active MySQL server to do a non-network upgrade, and in any case the consequence is not too terrible. The fact that the maintainers managed to break installations with their first attempt to fix this didn't give us too much confidence that we should take their *second* attempt to fix it with only three days before go/no-go; we felt a lot more comfortable sticking with a build that we at least know does not catastrophically break anything.
Comment 7 Fedora Update System 2013-06-29 14:43:24 EDT
mariadb-5.5.31-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.