Bug 976998 - [abrt] qtgpsc-0.3.1-6.fc19: gps_sock_read: Process /usr/bin/qtgpsc was killed by signal 11 (SIGSEGV)
[abrt] qtgpsc-0.3.1-6.fc19: gps_sock_read: Process /usr/bin/qtgpsc was killed...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qtgpsc (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
abrt_hash:6a832aa9cc09099efd21b1fb581...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-22 07:55 EDT by Herbert Carl Meyer
Modified: 2013-08-22 04:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 04:56:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (109.76 KB, text/plain)
2013-06-22 07:56 EDT, Herbert Carl Meyer
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-22 07:56 EDT, Herbert Carl Meyer
no flags Details
File: core_backtrace (249 bytes, text/plain)
2013-06-22 07:56 EDT, Herbert Carl Meyer
no flags Details
File: dso_list (14.25 KB, text/plain)
2013-06-22 07:56 EDT, Herbert Carl Meyer
no flags Details
File: environ (1.51 KB, text/plain)
2013-06-22 07:56 EDT, Herbert Carl Meyer
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-22 07:56 EDT, Herbert Carl Meyer
no flags Details
File: maps (44.15 KB, text/plain)
2013-06-22 07:56 EDT, Herbert Carl Meyer
no flags Details
File: open_fds (454 bytes, text/plain)
2013-06-22 07:56 EDT, Herbert Carl Meyer
no flags Details
File: proc_pid_status (769 bytes, text/plain)
2013-06-22 07:56 EDT, Herbert Carl Meyer
no flags Details
File: var_log_messages (380 bytes, text/plain)
2013-06-22 07:56 EDT, Herbert Carl Meyer
no flags Details

  None (edit)
Description Herbert Carl Meyer 2013-06-22 07:55:57 EDT
Description of problem:
Hardware is DeLorme lt-40, plugged into USB, gpsd running. lt-40 had been initialized by starting xgpsd. LT-40 had 3d lock, i quit xgpsd, started qtgpsc, pressed connect button to localhost.

Version-Release number of selected component:
qtgpsc-0.3.1-6.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        qtgpsc
crash_function: gps_sock_read
executable:     /usr/bin/qtgpsc
kernel:         3.9.6-301.fc19.i686.PAE
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 gps_sock_read at libgps_sock.c:154
 #1 gps_read at libgps_core.c:144
 #2 Gpsd::handleInput at /usr/src/debug/qtgpsc-0.3.1/src/gpsd.cpp:115
 #3 Gpsd::qt_static_metacall at /usr/src/debug/qtgpsc-0.3.1/src/moc_gpsd.cxx:110
 #4 QMetaObject::activate at kernel/qobject.cpp:3539
 #5 QSocketNotifier::activated at .moc/release-shared/moc_qsocketnotifier.cpp:102
 #6 QSocketNotifier::event at kernel/qsocketnotifier.cpp:317
 #7 QApplicationPrivate::notify_helper at kernel/qapplication.cpp:4562
 #8 QApplication::notify at kernel/qapplication.cpp:4348
 #9 QCoreApplication::notifyInternal at kernel/qcoreapplication.cpp:949
Comment 1 Herbert Carl Meyer 2013-06-22 07:56:01 EDT
Created attachment 764074 [details]
File: backtrace
Comment 2 Herbert Carl Meyer 2013-06-22 07:56:03 EDT
Created attachment 764075 [details]
File: cgroup
Comment 3 Herbert Carl Meyer 2013-06-22 07:56:06 EDT
Created attachment 764076 [details]
File: core_backtrace
Comment 4 Herbert Carl Meyer 2013-06-22 07:56:08 EDT
Created attachment 764077 [details]
File: dso_list
Comment 5 Herbert Carl Meyer 2013-06-22 07:56:11 EDT
Created attachment 764078 [details]
File: environ
Comment 6 Herbert Carl Meyer 2013-06-22 07:56:13 EDT
Created attachment 764079 [details]
File: limits
Comment 7 Herbert Carl Meyer 2013-06-22 07:56:15 EDT
Created attachment 764080 [details]
File: maps
Comment 8 Herbert Carl Meyer 2013-06-22 07:56:18 EDT
Created attachment 764081 [details]
File: open_fds
Comment 9 Herbert Carl Meyer 2013-06-22 07:56:20 EDT
Created attachment 764082 [details]
File: proc_pid_status
Comment 10 Herbert Carl Meyer 2013-06-22 07:56:22 EDT
Created attachment 764083 [details]
File: var_log_messages
Comment 11 Fabian Affolter 2013-08-22 04:56:55 EDT
This seems to be an upstream bug, report at http://code.google.com/p/qtgpsc/issues/list

Note You need to log in before you can comment on or make changes to this bug.