Bug 977022 - Multilib nspr version problem installing wine. Fedora 19
Multilib nspr version problem installing wine. Fedora 19
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nspr (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-22 12:56 EDT by javier del valle
Modified: 2013-06-25 13:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 13:16:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description javier del valle 2013-06-22 12:56:19 EDT
Description of problem:

I get en error when I try to install wine on Fedora 19 (beta) 

Version-Release number of selected component (if applicable):
Linux vv2-vv 3.9.6-301.fc19.x86_64 #1 SMP Mon Jun 17 14:26:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
yum-3.4.3-95.fc19.noarch

How reproducible:
Trying to install wine

Steps to Reproduce:
1. # yum install wine

Actual results:
...
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for nspr which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of nspr of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude nspr.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of nspr installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of nspr installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: nspr-4.9.6-1.fc19.i686 != nspr-4.10-1.fc19.x86_64
Error: Protected multilib versions: krb5-libs-1.11.3-1.fc19.i686 != krb5-libs-1.11.3-2.fc19.x86_64
Error: Protected multilib versions: 1:dbus-libs-1.6.8-5.fc19.i686 != 1:dbus-libs-1.6.12-1.fc19.x86_64
Error: Protected multilib versions: nss-softokn-3.14.3-1.fc19.i686 != nss-softokn-3.15-3.fc19.x86_64
Error: Protected multilib versions: glib2-2.36.3-1.fc19.i686 != glib2-2.36.3-2.fc19.x86_64
Error: Protected multilib versions: nss-3.14.3-13.0.fc19.i686 != nss-3.15-2.fc19.x86_64
Error: Protected multilib versions: graphite2-1.2.2-1.fc19.i686 != graphite2-1.2.2-2.fc19.x86_64
Error: Protected multilib versions: nss-util-3.14.3-1.fc19.i686 != nss-util-3.15-1.fc19.x86_64
Error: Protected multilib versions: nss-softokn-freebl-3.14.3-1.fc19.i686 != nss-softokn-freebl-3.15-3.fc19.x86_64
Error: Protected multilib versions: openldap-2.4.35-4.fc19.i686 != openldap-2.4.35-5.fc19.x86_64


Expected results:


Additional info:

Best regards
Comment 1 Elio Maldonado Batiz 2013-06-24 18:27:43 EDT
I don't think this is realated to nsp at all, worst case nss or nss-softokn if at all. This are the dependencies with -> meaning depend on or Requires:
 wine -> wine-ldap -> ldap -> nss -> nss-softokn/nss-util/nspr.
I tried to reproduced but I ended with a diffrent method that worked. I had my vm wine installed already. Updates testing wasn't enabled. So I did instead a 'yum --enablerepo=updates testing update nss' which completed okay.  I have seen someting like this before and it seems to depend on the method you use to update or install. I'll do some more investigating.
Comment 2 Elio Maldonado Batiz 2013-06-24 20:50:08 EDT
I keep trying but I can't reproduce the problem.
Comment 3 javier del valle 2013-06-25 03:42:59 EDT
Ok. I did:

# yum-config-manager --enable updates-testing
# yum update nss
Loaded plugins: langpacks, refresh-packagekit
rpmfusion-free                                           | 3.3 kB     00:00     
rpmfusion-free-updates                                   | 1.2 kB     00:00     
rpmfusion-free-updates-testing                           | 3.3 kB     00:00     
rpmfusion-nonfree                                        | 3.3 kB     00:00     
rpmfusion-nonfree-updates                                | 1.2 kB     00:00     
rpmfusion-nonfree-updates-testing                        | 3.3 kB     00:00     
updates/19/x86_64/metalink                               |  28 kB     00:00     
updates-testing/19/x86_64/metalink                       |  22 kB     00:00     
updates-testing                                          | 4.6 kB     00:00     
updates-testing/19/x86_64/primary_db                       | 9.4 MB   00:06     
Resolving Dependencies
--> Running transaction check
---> Package nss.x86_64 0:3.15-2.fc19 will be updated
--> Processing Dependency: nss = 3.15-2.fc19 for package: nss-sysinit-3.15-2.fc19.x86_64
--> Processing Dependency: nss(x86-64) = 3.15-2.fc19 for package: nss-tools-3.15-2.fc19.x86_64
---> Package nss.x86_64 0:3.15-5.fc19 will be an update
--> Running transaction check
---> Package nss-sysinit.x86_64 0:3.15-2.fc19 will be updated
---> Package nss-sysinit.x86_64 0:3.15-5.fc19 will be an update
---> Package nss-tools.x86_64 0:3.15-2.fc19 will be updated
---> Package nss-tools.x86_64 0:3.15-5.fc19 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package           Arch         Version             Repository             Size
================================================================================
Updating for dependencies:
 nss               x86_64       3.15-5.fc19         updates-testing       840 k
 nss-sysinit       x86_64       3.15-5.fc19         updates-testing        44 k
 nss-tools         x86_64       3.15-5.fc19         updates-testing       458 k

Transaction Summary
================================================================================
Upgrade             ( 3 Dependent packages)

Total download size: 1.3 M
Is this ok [y/d/N]: y
Downloading packages:
Not downloading Presto metadata for updates-testing
(1/3): nss-sysinit-3.15-5.fc19.x86_64.rpm                  |  44 kB   00:00     
nss-tools-3.15-5.fc19.x86_64.r FAILED                                          
http://mirror1.atrpms.net/fedora/linux/updates/testing/19/x86_64/nss-tools-3.15-5.fc19.x86_64.rpm: [Errno 14] HTTP Error 301 - Moved Permanently
Trying other mirror.
(2/3): nss-3.15-5.fc19.x86_64.rpm                          | 840 kB   00:01     
(3/3): nss-tools-3.15-5.fc19.x86_64.rpm                    | 458 kB   00:00     
--------------------------------------------------------------------------------
Total                                           1.1 MB/s | 1.3 MB     00:01     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : nss-3.15-5.fc19.x86_64                                       1/6 
  Updating   : nss-sysinit-3.15-5.fc19.x86_64                               2/6 
  Updating   : nss-tools-3.15-5.fc19.x86_64                                 3/6 
  Cleanup    : nss-tools-3.15-2.fc19.x86_64                                 4/6 
  Cleanup    : nss-sysinit-3.15-2.fc19.x86_64                               5/6 
  Cleanup    : nss-3.15-2.fc19.x86_64                                       6/6 
  Verifying  : nss-tools-3.15-5.fc19.x86_64                                 1/6 
  Verifying  : nss-sysinit-3.15-5.fc19.x86_64                               2/6 
  Verifying  : nss-3.15-5.fc19.x86_64                                       3/6 
  Verifying  : nss-tools-3.15-2.fc19.x86_64                                 4/6 
  Verifying  : nss-sysinit-3.15-2.fc19.x86_64                               5/6 
  Verifying  : nss-3.15-2.fc19.x86_64                                       6/6 

Dependency Updated:
  nss.x86_64 0:3.15-5.fc19              nss-sysinit.x86_64 0:3.15-5.fc19       
  nss-tools.x86_64 0:3.15-5.fc19       

Complete!

# yum install wine

and completed okay.

Thank you. It has been worth for me.
Comment 4 Elio Maldonado Batiz 2013-06-25 11:21:26 EDT
Hi Javier, 

Thank you for trying again. I'm glad is working out now for you. That problem mid-way is okay as it probably had problems with a specific mirror and it moved to a different one where it found the needed rpm. 

I have held back pushing it to stable pending resolution of this. If you have time, could you go offer some positive feedback at
https://admin.fedoraproject.org/updates/FEDORA-2013-11174/nss-3.15-5.fc19,nss-softokn-3.15-3.fc19,nss-util-3.15-1.fc19,nspr-4.10-2.fc19

Thanks,

-Elio
Comment 5 Elio Maldonado Batiz 2013-06-25 13:16:58 EDT
Closing it is NOTABUG. Please feel free to reopen it if the problem recurs.

Note You need to log in before you can comment on or make changes to this bug.