Bug 977060 - Xorg crash
Xorg crash
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-22 22:50 EDT by Christian Kujau
Modified: 2015-02-17 10:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 10:39:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log.old (33.46 KB, text/plain)
2013-06-22 22:50 EDT, Christian Kujau
no flags Details
/var/log/messages (617.51 KB, text/plain)
2013-06-22 22:52 EDT, Christian Kujau
no flags Details
lspci -nn (2.03 KB, text/plain)
2013-06-22 22:59 EDT, Christian Kujau
no flags Details
lspci -nn -vvv (12.47 KB, text/plain)
2013-06-22 23:00 EDT, Christian Kujau
no flags Details
lspci -nn (2.03 KB, text/plain)
2013-06-22 23:06 EDT, Christian Kujau
no flags Details
lspci -nn -vvv (22.75 KB, text/plain)
2013-06-22 23:06 EDT, Christian Kujau
no flags Details
dmesg, with drm.debug=14 log_buf_len=16M (160.58 KB, text/plain)
2013-06-22 23:26 EDT, Christian Kujau
no flags Details
Fedora 19 booting (3.70 MB, video/ogg)
2013-06-23 01:01 EDT, Christian Kujau
no flags Details

  None (edit)
Description Christian Kujau 2013-06-22 22:50:06 EDT
Created attachment 764231 [details]
Xorg.0.log.old

Description of problem:

I wanted to try Fedora 19 (Beta) on this MacBook Pro ("MacBookPro5,5"). Booting seems fine, but when it tried to start X11, the display just showed a gray surface, with intermittent blue and green lines flickering. On top and on the bottom of the screen there were gray/black stipes, kinda hard to describe and I didn't catch a picture. But it was very discomforting :-\

Anyway, X11 started, login went OK, after clicking around 1 minute (see the log), a newly opened terminal window wasn't reacting quite well: I couldn't resize it any more, I could still move the mouse but it was stuttering, as if the machine was incredibly busy or so. But it wasn't - and then I got logged out and was able to login again. According to Xorg.0.log, X11 crashed with a segfault.

Version-Release number of selected component (if applicable):

$ rpm -qa | egrep '^kernel|nouv'
kernel-modules-extra-3.9.2-301.fc19.x86_64
kernel-3.9.2-301.fc19.x86_64
xorg-x11-drv-nouveau-1.0.7-1.fc19.x86_64

How reproducible:

don't know, yet.

Steps to Reproduce:
1. Start Fedora F19 Beta off Live CD
2. Login to Xorg
3. 

Actual results:

Crash

Expected results:

Should not crash :-)

Additional info:

The errors in the kernel log look at lot like bug 845965. And the screen corruption just when X11 was starting look like bug 924385. But not quite, hence this new bug.
Comment 1 Christian Kujau 2013-06-22 22:52:28 EDT
Created attachment 764232 [details]
/var/log/messages
Comment 2 Christian Kujau 2013-06-22 22:59:33 EDT
Created attachment 764233 [details]
lspci -nn
Comment 3 Christian Kujau 2013-06-22 23:00:05 EDT
Created attachment 764234 [details]
lspci -nn -vvv
Comment 4 Christian Kujau 2013-06-22 23:05:37 EDT
Just after filling out this report, Xorg crashed again, 30min after boot.
Comment 5 Christian Kujau 2013-06-22 23:06:02 EDT
Created attachment 764235 [details]
lspci -nn
Comment 6 Christian Kujau 2013-06-22 23:06:55 EDT
Created attachment 764236 [details]
lspci -nn -vvv
Comment 7 Christian Kujau 2013-06-22 23:25:52 EDT
Rebooted with "drm.debug=14 log_buf_len=16M", the same "weird" screen appears, just before X11 starts. Got a picture this time, will upload later.

Started "Terminal", and after a few seconds the screen froze again - was remained frozen for ~2 minutes when I suspected it will crash again. But it didn't crash, it just resumed as if nothing happened. Similar TRAP messages in dmesg, to be attached.
Comment 8 Christian Kujau 2013-06-22 23:26:59 EDT
Created attachment 764237 [details]
dmesg, with drm.debug=14 log_buf_len=16M
Comment 9 Christian Kujau 2013-06-23 01:01:17 EDT
Created attachment 764238 [details]
Fedora 19 booting

I'm uploading this video to show the garbled screen I tried to describe earlier. While this bug report is about X11 crashing, maybe this is screen behaviour is a sign of something going wrong early on.
Comment 10 Fedora End Of Life 2015-01-09 13:30:21 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 11 Fedora End Of Life 2015-02-17 10:39:51 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.