Bug 977075 - nova [Negative]: no time out when instances fail to build
nova [Negative]: no time out when instances fail to build
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
unspecified
x86_64 Linux
medium Severity medium
: ---
: 6.0 (Juno)
Assigned To: Vladan Popovic
Ami Jeain
: FutureFeature, MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-23 05:52 EDT by Dafna Ron
Modified: 2016-04-26 10:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-12 16:51:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (3.04 MB, application/x-gzip)
2013-06-23 07:14 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2013-06-23 05:52:54 EDT
Description of problem:

I noticed that when there is a problem with instances they are stuck in build forever with no timeout. 
this has happened on my setup for a cinder issue (after restart of cinder the problem was fixed and might be related to build update) but I also reproduced it on other scenario in which I launched 10 instances and rebooted the host.
some of the instances were stuck in build state forever. 
 
perhaps it will be a good idea to create a time-out for status build and move instances to status Error

Version-Release number of selected component (if applicable):

openstack-nova-compute-2013.1.2-2.el6ost.noarch
openstack-nova-api-2013.1.2-2.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. launch 10 instances
2. reboot the host
3.

Actual results:

some vms move to error, some are stuck in build. 

Expected results:

we should have a time-out and move instances to Error state 

Additional info: logs
Comment 1 Dafna Ron 2013-06-23 07:14:29 EDT
Created attachment 764291 [details]
logs
Comment 2 Nikola Dipanov 2013-11-01 10:39:33 EDT
In most cases - if something is wrong with the instance - it should go to ERROR - however in cases like rebooting the host - it can happen that they stay in BUILD. 

Currently - the sync_power_states periodic task does not consider BUILD instances, and having a timeout (as opposed to just checking state as the periodic task does now) so this will require an upstream blueprint.

Moving to 5.0.
Comment 4 Stephen Gordon 2014-04-06 16:18:04 EDT
Vladan is this something that you have actively looked at or do I need to move to 6.0?
Comment 5 Vladan Popovic 2014-04-17 08:44:51 EDT
Sorry for the late response Stephen. 
Didn't manage to look at this still, so it should be moved to 6.0.
Comment 6 Russell Bryant 2014-06-12 16:51:57 EDT
Please report an upstream bug for this.  The upstream bug will need to contain a lot more detail about how to reproduce this scenario, though.

Note You need to log in before you can comment on or make changes to this bug.