This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 977096 - filesystem installation conflicts with google-earth stable
filesystem installation conflicts with google-earth stable
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: filesystem (Show other bugs)
19
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-23 10:06 EDT by klaus
Modified: 2016-05-05 03:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 02:48:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description klaus 2013-06-23 10:06:43 EDT
During latest update in Yumex I sadly got this error report:   

ERROR: Error in Yum-Transaktion: Test-Transaktion error: file /usr/bin from install of filesystem-3.2-12.fc19.i686 conflicts with file from package google-earth-stable-7.1.1.1580-0.i386

filesystem cannot be updated then.

No more information I do have for this error at this moment in time.
Please help, i can't/don't want't to leave filesystem without update and don't want it that conflict with google earth stable. Tell me where to look or with what information to provide you. Thanks.
Comment 1 Ondrej Vasik 2013-06-24 02:48:42 EDT
Thanks for report. Google earth package SHOULD NOT own /usr/bin directory. It is their packaging mistake, which violates Fedora packaging guidelines - see https://fedoraproject.org/wiki/Packaging:Guidelines#File_and_Directory_Ownership . Anyway - there was no change in permissions in /usr/bin subdir, so rpm should be normally tolerant to this ownership conflict - they are ignored, if the user/group ownership and permissions on the directory are the same.

That being said, you may open the rpm archive in e.g. midnight commander and check what permissions are set on /usr/bin in the cpio archives. It should have 555:root:root in both. I suspect there is default 755:root:root in the google earth package - but this is violation of Fedora packaging guidelines and their packaging mistake. It is even confirmed by them - see e.g. http://code.google.com/p/earth-issues/issues/detail?id=1525 . Closing NOTABUG.
Comment 2 Matheus Lança 2014-10-02 08:08:46 EDT
Hi guys, i don't know if this might resolve your problem, but i had the same problem and i find this to fix...

Source: www.centos.org/docs/5/html/Deployment_Guide-en-US/s1-rpm-using.html


10.2.2.2. Conflicting Files

If you attempt to install a package that contains a file which has already been installed by another package, the following is displayed:


Preparing...                ########################################### [100%] 
file /usr/bin/foo from install of foo-1.0-1 conflicts with file from package bar-2.0.20
To make RPM ignore this error, use the --replacefiles option:

rpm -ivh --replacefiles foo-1.0-1.i386.rpm

Good luck!
Comment 3 kilolima 2015-05-11 22:25:11 EDT
Same bug on Fedora 22. Yes, this is a bug, Google's fault or not, because Google Earth is still broken for users on Fedora. Three years+ later.
Comment 4 Ondrej Vasik 2015-06-12 06:51:17 EDT
I understand, but changing defaults in Fedora is not the right way. Permissions were reduced as part of "security hardening" - and I don't see any reason why google shouldn't drop their /usr/bin/ ownership from their packages. Easiest way (%exclude %dir %{_bindir} in %files section) - or if they have this intentionally listed in %files section, they should remove this line and/or change permissions according to filesystem package. (removal preferred).
Comment 5 Germano Massullo 2015-06-12 06:56:52 EDT
(In reply to kilolima from comment #3)
> Same bug on Fedora 22. Yes, this is a bug, Google's fault or not, because
> Google Earth is still broken for users on Fedora. Three years+ later.

you should complain at https://groups.google.com/a/googleproductforums.com/d/msgid/maps/e213f100-7a19-4ec5-a89f-5c503ec6ded0%40googleproductforums.com
Comment 6 Clemens Eisserer 2016-05-05 03:50:17 EDT
Still an issue with F23 + latest stable google-earth version.

The google-forum entry has been locked, while the issue still persists - seems google doesn't really care...

Note You need to log in before you can comment on or make changes to this bug.