This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 977150 - Licq not works in F18
Licq not works in F18
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: licq (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-23 15:26 EDT by Eugene A. Pivnev
Modified: 2013-08-16 19:05 EDT (History)
2 users (show)

See Also:
Fixed In Version: licq-1.7.1-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 19:03:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene A. Pivnev 2013-06-23 15:26:47 EDT
Description of problem:
licq can't start.

Version-Release number of selected component (if applicable):
licq-1.6.1-3.fc18.i686

How reproducible:

Steps to Reproduce:
1. [sudo] yum install licq
2. licq

Actual results:
bash-4.2$ LC_ALL=C licq                                                                                      
23:22:26.336 [ERR] licq: Unable to load plugin (/usr/lib/licq/protocol_jabber.so): /usr/lib/licq/protocol_jabber.so: cannot open shared object file: No such file or directory
Comment 1 Fedora Admin XMLRPC Client 2013-07-30 04:44:21 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Christopher Meng 2013-07-30 04:47:17 EDT
Hi Eugene,

Can you reproduce on 1.7.1 version now?

If not I'll close it.
Comment 3 Eugene A. Pivnev 2013-07-30 04:59:34 EDT
(In reply to Christopher Meng from comment #2)
> Hi Eugene,
> 
> Can you reproduce on 1.7.1 version now?
> 
> If not I'll close it.

bash-4.2$ LC_ALL=C licq                                                                                                                                      
12:58:38.241 [ERR] licq: Unable to load plugin (/usr/lib/licq/protocol_jabber.so): /usr/lib/licq/protocol_jabber.so: cannot open shared object file: No such file or directory                                                                                                                                            
bash-4.2$ rpm -q licq                                                                                                                                        
licq-1.7.1-1.fc19.i686
Comment 4 Eugene A. Pivnev 2013-07-31 05:27:59 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=5682946

--- licq.spec.orig      2013-07-31 12:58:22.402695914 +0400
+++ licq.spec   2013-07-31 13:13:04.255953191 +0400
@@ -1,6 +1,6 @@
 Name: licq
 Version: 1.7.1
-Release: 1%{?dist}
+Release: 2%{?dist}
 License: GPLv2+
 Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
 
@@ -15,6 +15,7 @@
 BuildRequires: gettext, cmake
 BuildRequires: xosd-devel
 BuildRequires: cdk-devel ncurses-devel
+BuildRequires: gloox-devel
 
 # fcami - licq calls "play" directly
 Requires: sox
@@ -83,6 +84,13 @@
 make %{?_smp_mflags}
 popd
 
+pushd plugins/jabber
+mkdir build
+cd build
+%cmake $cmakeopts ..
+make %{?_smp_mflags}
+popd
+
 pushd plugins/msn
 mkdir build
 cd build
@@ -138,6 +146,10 @@
 make DESTDIR=$RPM_BUILD_ROOT install
 popd
 
+pushd plugins/jabber/build
+make DESTDIR=$RPM_BUILD_ROOT install
+popd
+
 pushd plugins/msn/build
 make DESTDIR=$RPM_BUILD_ROOT install
 popd
@@ -173,6 +185,7 @@
 %{_libdir}/licq/licq_autoreply.so
 %{_libdir}/licq/licq_forwarder.so
 %{_libdir}/licq/licq_rms.so
+%{_libdir}/licq/protocol_jabber.so
 %{_datadir}/licq
 %{_datadir}/applications/*licq.desktop
 %doc doc/ upgrade/ README* LICENSE
@@ -189,6 +202,9 @@
 %doc plugins/console/{README,licq_console.conf}
 
 %changelog
+* Wed Jul 31 2013 TI_Eugene <fcami@fedoraproject.org> - 1.7.1-2
+- Jabber protocol added.
+
 * Sun Jun 02 2013 François Cami <fcami@fedoraproject.org> - 1.7.1-1
 - New upstream release.
Comment 5 Christopher Meng 2013-08-02 02:14:03 EDT
Thanks.

This package needs some big work, I may rewrite the spec.

Please wait a moment or few days.

Thanks.
Comment 6 Fedora Update System 2013-08-08 22:20:51 EDT
licq-1.7.1-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/licq-1.7.1-4.fc18
Comment 7 Fedora Update System 2013-08-08 22:22:49 EDT
licq-1.7.1-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/licq-1.7.1-4.fc19
Comment 8 Fedora Update System 2013-08-09 23:55:48 EDT
Package licq-1.7.1-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing licq-1.7.1-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14547/licq-1.7.1-4.fc18
then log in and leave karma (feedback).
Comment 9 Eugene A. Pivnev 2013-08-10 03:46:42 EDT
Works for me
Comment 10 Christopher Meng 2013-08-15 22:15:47 EDT
(In reply to Eugene A. Pivnev from comment #9)
> Works for me

Please leave karma.

Thanks.
Comment 11 Fedora Update System 2013-08-16 19:03:44 EDT
licq-1.7.1-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-08-16 19:05:19 EDT
licq-1.7.1-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.