Bug 977164 - Issues with importing some .png files.
Issues with importing some .png files.
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CCMS-Core (Show other bugs)
1.0
Unspecified Unspecified
low Severity low
: ---
: 1.1
Assigned To: Lee Newson
Jared MORGAN
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-23 20:36 EDT by Jared MORGAN
Modified: 2015-08-09 21:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 21:11:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diagram-jcr-cluster which is the same file present in (58.85 KB, image/png)
2013-06-23 20:36 EDT, Jared MORGAN
no flags Details

  None (edit)
Description Jared MORGAN 2013-06-23 20:36:50 EDT
Created attachment 764377 [details]
diagram-jcr-cluster which is the same file present in

Description of problem:

After importing some PNG files, the files seem to be missing a layer or two.


Version-Release number of selected component (if applicable):

pressgang-next UI

How reproducible:

100%

Steps to Reproduce:
1. Open Image file 
2. Open the attached file of the original image
3. Observer results

Actual results:

Layers in the image preview are missing.

Expected results:

Layers in the image preview are present.

Additional info:

I have not yet included this image in a book build. I will insert it into the Development Guide and see if it is just the image preview that is the issue.
Comment 1 Lee Newson 2013-07-03 23:04:39 EDT
I can replicate this, however the issue is only in the UI preview, so I'm going to mark this as low priority for now. If you click the "View Image" button, it'll display the original image that will be included in any output.
Comment 2 Lee Newson 2013-07-03 23:31:54 EDT
Moving this to CCMS-Core, as the problem lies in an invalid Base64 string being created by the server when the image is created/updated.
Comment 3 Lee Newson 2013-07-16 00:53:20 EDT
Fixed in 1.1-SNAPSHOT 20130701-0911.

The problem was due to the way the Base64 encoded and thumbnail images were being created on the server. They were all being processed as a JPG, so if the image had transparency layers (ie a png), than they would be lost in the conversion like in the bug report.

Now all Base64 encoding is done on the original image, so it should always display the same as the uploaded content and thumbnails are processed based on the image type (ie JPG, GIF, PNG or SVG), with JPG being the default when the type can't be determined.

Note: This can only be verified on the dev-server at this stage (see image 2836 for the attached image). I've also ran a script to fix all old images that exist on the dev-server.

Note You need to log in before you can comment on or make changes to this bug.