Bug 977172 - gnuradio-companion segfault on startup Fedora 18
gnuradio-companion segfault on startup Fedora 18
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnuradio (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
: 980494 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-23 22:02 EDT by Richard Chan
Modified: 2013-10-08 07:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: gnuradio-3.6.5-3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 21:42:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Chan 2013-06-23 22:02:06 EDT
Description of problem:
gnuradio-companion segfault on startup


Version-Release number of selected component (if applicable):
3.6.5-2.fc18

How reproducible:
Always

Steps to Reproduce:
1. gnuradio-companion
2.
3.

Actual results:
### I do not have UHD hardware
$ gnuradio-companion
Segmentation fault (core dumped)

[172585.991416] traps: gnuradio-compan[5107] general protection ip:7f43c49bab4b sp:7fffdc89b410 error:0 in _uhd_swig.so[7f43c493a000+ef000]


Expected results:
gnuradio flow graph editor window


Additional info:
No ETTUS hardware
Only RTL SDR hardware
Comment 1 Fedora Update System 2013-06-24 08:27:16 EDT
gnuradio-3.6.5-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnuradio-3.6.5-3.fc19
Comment 2 Fedora Update System 2013-06-24 08:30:11 EDT
gnuradio-3.6.5-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnuradio-3.6.5-3.fc18
Comment 3 Richard Chan 2013-06-24 11:39:01 EDT
I confirm that the update fixes the startup problems.
Comment 4 Jaroslav Škarvada 2013-06-24 11:51:30 EDT
(In reply to Richard Chan from comment #3)
> I confirm that the update fixes the startup problems.

Ok, thanks for the report and confirmation of the fix.
Comment 5 Fedora Update System 2013-06-24 14:48:51 EDT
Package gnuradio-3.6.5-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnuradio-3.6.5-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11591/gnuradio-3.6.5-3.fc19
then log in and leave karma (feedback).
Comment 6 Jaroslav Škarvada 2013-07-02 10:19:22 EDT
*** Bug 980494 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2013-07-02 21:42:57 EDT
gnuradio-3.6.5-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-10-08 07:36:04 EDT
gnuradio-3.6.5-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.