Bug 977210 - quota: soft-timeout and hard-timeout seems missing from quotad.vol
quota: soft-timeout and hard-timeout seems missing from quotad.vol
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Krutika Dhananjay
Saurabh
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 01:21 EDT by Saurabh
Modified: 2016-01-19 01:12 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 05:25:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-06-24 01:21:01 EDT
Description of problem:
as per the information that I have the options,
option dist-rep.hard-timeout 2
option dist-rep.soft-timeout 10
should have been mentioned in quotad.vol

On this release they are found there.

[root@quota1 ~]# less /var/lib/glusterd/quotad/quotad.vol  | grep timeout
[root@quota1 ~]# 




Version-Release number of selected component (if applicable):
[root@quota1 ~]# rpm -qa | grep glusterfs
glusterfs-3.4rhs-1.el6rhs.x86_64
glusterfs-fuse-3.4rhs-1.el6rhs.x86_64
glusterfs-server-3.4rhs-1.el6rhs.x86_64

How reproducible:
always
Comment 2 Krutika Dhananjay 2013-06-24 03:29:18 EDT
Saurabh,

These are default values, which is why they are not displayed in quotad.vol. However, if you explicitly configure their values through 'volume quota' interface, they must appear in the volfile.
Comment 3 Saurabh 2013-06-26 02:29:26 EDT
if you look into the standards of other volume files like in nfs-server.vol

the default values are also displayed. 

Please update the quotad related file with the default values
Comment 4 Krutika Dhananjay 2013-07-16 06:42:58 EDT
These default values don't need to be written into the volfile. This is because every xlator will have its own options table from which it fetches the default value of the option if it is not present already in the volfile.

It's only when the value is reconfigured (via volume 'quota soft-timeout' interface) that glusterd needs to notify quotad with the changes written in volfile.

So long as the deviation of an option value from its default value is reflected in the volfile and notify quotad of the change (which we do already), we're safe.
Comment 5 Krutika Dhananjay 2013-07-17 05:25:32 EDT
On second thought, I am moving the bug to CLOSED state for reasons stated in comment #4.

Also you may have noticed that the functionality of quotad does not get affected by the default values being present or not present in the volfile. This is because quotad is itself aware of the default values for these options.

Note You need to log in before you can comment on or make changes to this bug.