Bug 977264 - Business Central cannot be deployed on EAP6.1 in domain mode
Business Central cannot be deployed on EAP6.1 in domain mode
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Deployment (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Maciej Swiderski
Radovan Synek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 03:53 EDT by Radovan Synek
Modified: 2013-07-17 04:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 04:24:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server log from the first node (40.76 KB, text/x-log)
2013-06-24 03:53 EDT, Radovan Synek
no flags Details
domain.xml config (71.05 KB, text/xml)
2013-06-24 03:53 EDT, Radovan Synek
no flags Details
host.xml config (2.90 KB, text/xml)
2013-06-24 03:54 EDT, Radovan Synek
no flags Details

  None (edit)
Description Radovan Synek 2013-06-24 03:53:00 EDT
Created attachment 764474 [details]
server log from the first node

Having EAP 6.1 in a domain mode - single server group with two servers. When deploying Business Central via jboss-cli, the deployment fails and server log contains error "org.apache.lucene.store.LockObtainFailedException: Lock obtain timed out: NativeFSLock@/home/rsynek/temp/clustering/jboss-eap-6-domain/.index/write.lock"
The file write.lock does not exist.

See the attached server log for the stacktrace. I am also attaching domain.xml and host.xml
Comment 1 Radovan Synek 2013-06-24 03:53:36 EDT
Created attachment 764475 [details]
domain.xml config
Comment 2 Radovan Synek 2013-06-24 03:54:08 EDT
Created attachment 764476 [details]
host.xml config
Comment 3 Maciej Swiderski 2013-07-15 07:56:30 EDT
this issue is seen because kie-wb application includes search capabilities that are based on Apache Lucene. When running in cluster mode the location of the index must be separated - meaning each server in the cluster must have dedicated location where the index will be stored. It can be configured with additional system property that must be set on application server (host) level:

name: org.kie.kieora.index.dir
value: absolute path where the index files should be stored (inside the folder there will be .index folder with all index files).

This is due to Lucene is currently not clustered and it's rebuild on every server instance based on VFS.
the configuration is similar to how VFS files (.niogit) are maintained within cluster - each server instance has dedicated location.
Comment 4 Radovan Synek 2013-07-17 04:24:13 EDT
This solution (setting org.kie.kieora.index.dir property) works. Thanks Maciej!

=> Closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.