Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 977279 - poor handling of disks that report no media present
Summary: poor handling of disks that report no media present
Keywords:
Status: CLOSED DUPLICATE of bug 960794
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a608d184ffc75f1191872e71c52...
Depends On: 960794
Blocks: F19Blocker, F19FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-06-24 08:24 UTC by Dan Mashal
Modified: 2013-06-25 00:47 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-25 00:47:54 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (712.53 KB, text/plain)
2013-06-24 08:24 UTC, Dan Mashal
no flags Details
File: anaconda.log (13.92 KB, text/plain)
2013-06-24 08:24 UTC, Dan Mashal
no flags Details
File: environ (441 bytes, text/plain)
2013-06-24 08:24 UTC, Dan Mashal
no flags Details
File: lsblk_output (1.24 KB, text/plain)
2013-06-24 08:24 UTC, Dan Mashal
no flags Details
File: nmcli_dev_list (3.40 KB, text/plain)
2013-06-24 08:24 UTC, Dan Mashal
no flags Details
File: os_info (179 bytes, text/plain)
2013-06-24 08:24 UTC, Dan Mashal
no flags Details
File: program.log (20.05 KB, text/plain)
2013-06-24 08:25 UTC, Dan Mashal
no flags Details
File: storage.log (55.85 KB, text/plain)
2013-06-24 08:25 UTC, Dan Mashal
no flags Details
File: syslog (131.86 KB, text/plain)
2013-06-24 08:25 UTC, Dan Mashal
no flags Details
File: ifcfg.log (576 bytes, text/plain)
2013-06-24 08:25 UTC, Dan Mashal
no flags Details
File: packaging.log (339.21 KB, text/plain)
2013-06-24 08:25 UTC, Dan Mashal
no flags Details

Description Dan Mashal 2013-06-24 08:24:36 UTC
Description of problem:
Deleted a partition in custom partitioning

Version-Release number of selected component:
anaconda-19.30.9-1

The following was filed automatically by anaconda:
anaconda 19.30.9-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/platform.py", line 107, in bestDiskLabelType
    labelType = self.requiredDiskLabelType(device.partedDevice.type)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 816, in initializeDisk
    labelType = _platform.bestDiskLabelType(disk)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2022, in _destroy_device
    self.__storage.initializeDisk(device)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2148, in on_remove_clicked
    self._destroy_device(device)
AttributeError: 'NoneType' object has no attribute 'type'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-TC6\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-TC6

Comment 1 Dan Mashal 2013-06-24 08:24:41 UTC
Created attachment 764492 [details]
File: anaconda-tb

Comment 2 Dan Mashal 2013-06-24 08:24:45 UTC
Created attachment 764493 [details]
File: anaconda.log

Comment 3 Dan Mashal 2013-06-24 08:24:49 UTC
Created attachment 764494 [details]
File: environ

Comment 4 Dan Mashal 2013-06-24 08:24:52 UTC
Created attachment 764495 [details]
File: lsblk_output

Comment 5 Dan Mashal 2013-06-24 08:24:56 UTC
Created attachment 764496 [details]
File: nmcli_dev_list

Comment 6 Dan Mashal 2013-06-24 08:24:59 UTC
Created attachment 764497 [details]
File: os_info

Comment 7 Dan Mashal 2013-06-24 08:25:04 UTC
Created attachment 764498 [details]
File: program.log

Comment 8 Dan Mashal 2013-06-24 08:25:08 UTC
Created attachment 764499 [details]
File: storage.log

Comment 9 Dan Mashal 2013-06-24 08:25:11 UTC
Created attachment 764500 [details]
File: syslog

Comment 10 Dan Mashal 2013-06-24 08:25:14 UTC
Created attachment 764501 [details]
File: ifcfg.log

Comment 11 Dan Mashal 2013-06-24 08:25:18 UTC
Created attachment 764502 [details]
File: packaging.log

Comment 12 David Lehman 2013-06-24 16:06:19 UTC
Looks like we need to better protect against devices that somehow appear as disks yet also report no media present.

In the meantime, you can unplug your iphone while you are installing an OS on your system.

Comment 13 Dan Mashal 2013-06-24 17:03:17 UTC
Nominating as a blocker as anaconda fails to install.

Comment 14 Adam Williamson 2013-06-24 17:03:53 UTC
dlehman: is #960794 the same? the tracebacks look almost identical.

Comment 15 Brian Lane 2013-06-25 00:47:54 UTC

*** This bug has been marked as a duplicate of bug 960794 ***


Note You need to log in before you can comment on or make changes to this bug.