Bug 977299 - RFE - update root in epel6 to something newer.
RFE - update root in epel6 to something newer.
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: root (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mattias Ellert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 05:09 EDT by Steve Traylen
Modified: 2013-07-13 16:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: root-5.34.09-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-07 20:53:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Traylen 2013-06-24 05:09:44 EDT
Hi,

I have various requests for the root version within EPEL6 in particular
to move to something newer than the current root-5.28.00h-3.el6.

Can this happen?

Many Thanks

Steve.
Comment 1 Mattias Ellert 2013-06-24 05:56:01 EDT
I have had this request a few times before.

There is a stability criteria in EPEL that updates should not cause backward incompatibilities. Updating to a new base release of root will cause the soname of all root libraries to change, e.g. libCore.so.5.28 → libCore.so.5.34. So things that users have compiled against the existing version would need to be recompiled.

This is the reason I have so far not updated root to new base releases in stable distributions.

This stability criteria can be somewhat relaxed if the package in question is a leaf package. For the distribution (Fedora/EPEL) root is a leaf package since it does not have any packages depending on it. So from this point of view an update could be considered despite the introduced backward incompatibility. However, the issue of user code having been compiled against the root libraries that will break if root is updated still exists.

So there is a conflict between the desire to have the latest version in EPEL and having a stable binary version. It is not possible to have both. As a maintainer I have to choose one of the two. If the users of the root packages in EPEL agree that newer versions are more important than version stability I can change the maintenance strategy to accommodate that. But it would need to be a general opinion shared by most of the users, not the opinion of a few.

I don't know how to gauge the opinion of the users in a reliable way on this issue. Obviously, those that want the newest version approach are heard more loudly since those are the ones that want a change. The users who value the stable version approach are currently not heard since it is not clear to them that they should voice their opinion.

I am not dead set against updating, but it needs to be done after some reflection of the consequences.
Comment 2 Fedora Update System 2013-06-28 04:47:43 EDT
root-5.34.09-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/root-5.34.09-1.el5
Comment 3 Fedora Update System 2013-06-28 04:47:59 EDT
root-5.34.09-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/root-5.34.09-1.fc19
Comment 4 Fedora Update System 2013-06-28 04:48:13 EDT
root-5.34.09-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/root-5.34.09-1.fc18
Comment 5 Fedora Update System 2013-06-28 04:48:26 EDT
root-5.34.09-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/root-5.34.09-1.el6
Comment 6 Fedora Update System 2013-06-28 14:51:06 EDT
Package root-5.34.09-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing root-5.34.09-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-10652/root-5.34.09-1.el6
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-07-07 20:53:43 EDT
root-5.34.09-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-07-08 21:31:52 EDT
root-5.34.09-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-07-13 16:15:14 EDT
root-5.34.09-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-07-13 16:15:41 EDT
root-5.34.09-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.