Bug 977300 - Project name is not set while installing or deploying project via REST API
Project name is not set while installing or deploying project via REST API
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Mark Proctor
Ivo Bek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 05:10 EDT by Ivo Bek
Modified: 2014-08-06 16:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-06-24 05:10:01 EDT
Description of problem:

In this file "https://github.com/droolsjbpm/kie-wb-common/blob/master/kie-wb-common-services/kie-wb-common-rest/src/main/java/org/kie/workbench/common/services/rest/ProjectResource.java" you forgot to set project name to the jobrequest variable in some methods, compileProject(), installProject(), testProject() and deployProject. Please check all methods in the file that they will work in next version.

Also I have issues with injection of RepositoryService repositoryService; there, so please fix it or remove it if it's redundant.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Ivo Bek 2013-06-24 07:16:34 EDT
Please ignore the RepositoryService paragraph, I tried that again and it's already fixed or the error was caused by something else.
Comment 3 Ivo Bek 2013-09-09 04:44:50 EDT
Verified in BPMS 6.0.0.ER2

Note You need to log in before you can comment on or make changes to this bug.