Bug 977301 - leaked "<rhn-require ..." tag in Satellite's HTML
leaked "<rhn-require ..." tag in Satellite's HTML
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Dobes
Jiří Mikulka
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2013-06-24 05:20 EDT by Jan Hutař
Modified: 2014-10-06 09:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-java-2.0.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:55:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-06-24 05:20:24 EDT
Description of problem:
When I'm channel management -> Packages -> List / Remove, "Compare packages" action is strangely indented. Looking into HTML code of the page shows incorrect HTML markup (maybe leaked JSP tags?).


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. On webUI: Channels -> Manage Software Channels -> <some_channel> -> Packages -> List / Remove
2. Check HTML around "Compare Packages"


Actual results:
<ul>
  <li>
    <a href="/rhn/channels/manage/ChannelPackages.do?cid=103">
	  List / Remove Packages
	</a>
  </li>
  <li>
    <a href="/rhn/channels/manage/ChannelPackagesAdd.do?cid=103">
          Add Packages
        </a>
  </li>
  <rhn-require acl_mixins="RHN::Access::Channel" acl="not channel_packaging_type(sysv-solaris)">
    <li>
      <a href="/network/software/channels/manage/packages/compare/index.pxt?cid=103">
	  Compare Packages
	</a>
    </li>
  </rhn-require>
</ul>


Expected results:
No such tags there.
Comment 1 Jan Dobes 2013-06-25 05:34:01 EDT
removed in spacewalk master commit: 80f24c2e97504665a5ee039e8864cceffc297b26
Comment 4 Clifford Perry 2013-10-01 17:55:25 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.