Bug 977305 - multipath -t report the error queue_without_daemon value
multipath -t report the error queue_without_daemon value
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: LVM and device-mapper development team
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 05:33 EDT by Xiaowei Li
Modified: 2015-01-26 19:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 19:28:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaowei Li 2013-06-24 05:33:34 EDT
Description of problem:


Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.9-51.el7.x86_64


How reproducible:
100%

Steps to Reproduce:

# multipathd forcequeueing daemon
ok
# multipathd show config > /opt/1
# multipath -t > /opt/2
# diff /opt/1 /opt/2
17c17
< 	queue_without_daemon "forced"
---
> 	queue_without_daemon "no"

Actual results:
multipath -t report the previous queue_without_daemon value

Expected results:


Additional info:
Comment 2 Ben Marzinski 2013-06-26 19:28:10 EDT
Since you're manually setting the state of the daemon, it's going to be different than the configuration file.  There is no way for the multipath command to know that you did this.   Also, there is no reason for it to really care.  queue_without_daemon "no" simply turns queuing off when the multipathd daemon exist.  The multipath command never checks the queue_without_daemon value except to print it with -t. Thus, it's perfectly safe for it to not know that you manually overrode the configuration on the daemon.

Note You need to log in before you can comment on or make changes to this bug.