Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 977315 - An exception occurred when configuring ipv4 with dhcp failed
Summary: An exception occurred when configuring ipv4 with dhcp failed
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Mike Burns
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-24 10:00 UTC by wanghui
Modified: 2016-04-26 15:52 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-26 05:21:09 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description wanghui 2013-06-24 10:00:02 UTC
Description of problem:
Firstly you have configured ipv4 network using dhcp mode without an available dhcp server. Then it will report "An exception occured 'tuple' object has no attribute 'items' " when you configure the NIC again.

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-0.999.999.20130603183100git6c4298c.811.fc18.iso
ovirt-node-3.0.0-0.999.20130607080023git96bef11.fc18.noarch 

How reproducible:
100%

Steps to Reproduce:
1. Install ovirt-node-3.0.0-0.999.999.20130603183100git6c4298c.811.fc18.
2. Configure network of IPv4 using dhcp mode without an available dhcp server.
3. Select the NIC.

Actual results:
After step3, it reports "An exception occured 'tuple' object has no attribute 'items'".

Expected results:
After step3,it can configure the NIC.

Additional info:

Comment 1 Fabian Deutsch 2013-06-24 10:36:13 UTC
(In reply to wanghui from comment #0)
> Description of problem:
> Firstly you have configured ipv4 network using dhcp mode without an
> available dhcp server. Then it will report "An exception occured 'tuple'
> object has no attribute 'items' " when you configure the NIC again.
> 
> Version-Release number of selected component (if applicable):
> ovirt-node-iso-3.0.0-0.999.999.20130603183100git6c4298c.811.fc18.iso
> ovirt-node-3.0.0-0.999.20130607080023git96bef11.fc18.noarch 

I can't reproduce this with a recent build e.g.
http://jenkins.ovirt.org/view/ovirt_node/job/ovirt-node-iso-devel/2595/

And a lot in the networking code has changed since those two builds which are given above.

Could you re-test this with a recent build?

Comment 2 wanghui 2013-06-26 05:21:09 UTC
hi Fabian,

I have already re-tested in the recent build ovirt-node-iso-3.0.0-0.999.999.20130625144130gitd26f7bf.2621.fc18.iso and it did fixed this issue.

Thanks
huiwa


Note You need to log in before you can comment on or make changes to this bug.