Bug 977322 - rest-api: Missing node <snapshot_states> in /api/capabilities
rest-api: Missing node <snapshot_states> in /api/capabilities
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.2.0
All Linux
unspecified Severity low
: ---
: 3.3.0
Assigned To: Ori Liel
Elena
infra
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 06:20 EDT by Jakub Libosvar
Modified: 2016-02-10 14:40 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
/api/capabilities now lists the state of snapshots, for example "locked" or "ok".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 02:21:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Libosvar 2013-06-24 06:20:42 EDT
Description of problem:
/api/capabilities doesn't enumerate states which can snapshots have

Version-Release number of selected component (if applicable):
rhevm-restapi-3.2.1-0.31.el6ev.noarch


How reproducible:
Always

Steps to Reproduce:
1. Go to <rhevm_host>/api/capabilities
2. Search for statuses of snapshots
3.

Actual results:
No enumeration of snapshots' states

Expected results:
Something like:
<snapshot_states>
<snapshot_state>locked</snapshot_state>
<snapshot_state>ok</snapshot_state>
<snapshot_state>something_else</snapshot_state>
</snapshot_states>

Additional info:
Comment 1 Ori Liel 2013-08-12 09:18:23 EDT
patch posted upstream: 

  http://gerrit.ovirt.org/#/c/17970/
Comment 4 Charlie 2013-11-27 19:14:59 EST
This bug is currently attached to errata RHEA-2013:15231. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.