Bug 977332 - sections cannot define a related topic
sections cannot define a related topic
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CCMS-Core (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
Douglas Silas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 06:35 EDT by Eva Kopalova
Modified: 2016-06-17 17:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.33.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:37:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eva Kopalova 2013-06-24 06:35:56 EDT
Description of problem:
sections cannot define a related topic 

How reproducible:

  Chapter: Introduction to the environment [16826] 
    Section: Repository [13963][R: 18115]
      Creating a repository [18111]
      Cloning a repository [18112]
      Deleting a repository [18113]
      Connecting to a Service Repository [18018]
    Section: Project [18115]


Actual results:
csprocessor push userGuide.contentspec
CSProcessor client version: 0.32.3
Loading configuration from /home/eko/.config/csprocessor.ini
Connecting to PressGang server: http://skynet.usersys.redhat.com:8080/TopicIndex/

Starting to parse...
Starting first validation pass...
ERROR: Line 28: Invalid Chapter! Relationships can't be used for a Chapter.
       -> Section: Repository [13963] [R: 18511]
ERROR: Line 28: Invalid Section! No title.
       -> Section: 
ERROR: The Content Specification is not valid.
Comment 1 Lee Newson 2013-06-26 23:27:33 EDT
Fixed in 0.33.0

Levels can now have relationships applied to them when a Front Matter Topic exists for the level, otherwise you'll get the above error message.
Comment 2 Lee Newson 2013-06-27 23:12:51 EDT
0.33.0 has now been released.
Comment 5 Lee Newson 2013-09-30 19:37:40 EDT
I'm going to close this, since Eva is no longer with Red Hat. If it doesn't work than please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.