Bug 97734 - User Account module crashed if username has whitespace in it
User Account module crashed if username has whitespace in it
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: firstboot (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-19 17:18 EDT by Louis Bertrand
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-01 15:53:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Louis Bertrand 2003-06-19 17:18:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2)
Gecko/20030208 Netscape/7.02

Description of problem:
Python TypeError
modules/create_user.py in isUsernameOk
self.showErrorMessage(_("The user name '%s' contains whitespace. "
TypeError: not enough arguments for format string

I was trying combinations of bad user input and this is the only problem I
noticed so far.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run firstboot from the command line /usr/sbin/firstboot
2. at the user setup, enter a user name with whitespace in it
3. click forward and you'll see the error modal box
    

Actual Results:  Modal error box comes up:
modules/create_user.py in isUsernameOk
self.showErrorMessage(_("The user name '%s' contains whitespace. "
TypeError: not enough arguments for format string



Expected Results:  error message box saying you can't have whitespace in a user name

Additional info:

I'm not sure what the problem is, but when I did a copy and paste from the code
to produce the error message below the check for whitespace (checking for
punctuation in the user name), the problem was fixed. I don't understand what
you're doing with these multiline strings (me, I'd use the triple-quoted
strings), maybe it's an indentation thing too.
Comment 1 Brent Fox 2003-07-01 15:53:02 EDT
I committed a fix for this to cvs on May 30.  This should be fixed in
firstboot-1.0.11-1 and later in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.