Bug 977344 - Seam example: spring - spring AOP exception while logging in
Seam example: spring - spring AOP exception while logging in
Status: CLOSED WORKSFORME
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 2.4.0
Assigned To: Marek Novotny
Marek Schmidt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 06:55 EDT by Marián Labuda
Modified: 2013-06-27 05:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
mnovotny to provide: Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 05:45:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marián Labuda 2013-06-24 06:55:36 EDT
Describe the issue: 
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'userService' defined in ServletContext resource [/WEB-INF/applicationContext.xml]: Initialization of bean failed; nested exception is org.springframework.aop.framework.AopConfigException: Could not generate CGLIB subclass of class [class org.jboss.seam.example.spring.UserService]: Common causes of this problem include using a final class or a non-visible class; nested exception is net.sf.cglib.core.CodeGenerationException: java.lang.reflect.InvocationTargetException-->null

root cause is java.lang.SecurityException: class "org.jboss.seam.example.spring.UserService$$EnhancerByCGLIB$$e4518db2"'s signer information does not match signer information of other classes in the same package


How reproducible:
deploy example spring on EAP 6.1 and try to log in with default demo/demo.

Version:
seam 2.3.1 Final examples in WFK 2.3.0 ER1
tested in JBDS 7.0.0. Beta 2 on EAP 6.1

Note You need to log in before you can comment on or make changes to this bug.