Bug 977351 - Changing vmpool's quota is ignored.
Summary: Changing vmpool's quota is ignored.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.2.2
Assignee: ofri
QA Contact: Ondra Machacek
URL:
Whiteboard: sla
Depends On: 966003
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-24 11:23 UTC by Idith Tal-Kohen
Modified: 2018-12-02 16:56 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, it appeared that users could edit the quota of a virtual machine pool using the Edit Pool window, because the quota field was enabled. The quota field is now disabled when editing a pool.
Clone Of: 966003
Environment:
Last Closed: 2013-08-13 13:07:26 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1149 0 normal SHIPPED_LIVE rhevm bug fix update 2013-08-13 17:06:36 UTC
oVirt gerrit 15320 0 None None None Never

Description Idith Tal-Kohen 2013-06-24 11:23:18 UTC
+++ This bug was initially created as a clone of Bug #966003 +++

Description of problem:
When quota of vmpools is changed the new value is ignored and the old one stay assigned to vmpool.

Version-Release number of selected component (if applicable):
sf17

How reproducible:
always

Steps to Reproduce:
1. Set DC to enforced or audit mode.
2. Create quota1 and quota2.
3. Create vmpool with quota1 assigned.
4. Reassign quota2 to vmpool.

Actual results:
After quota2 is assigned to pool. quota1 is still assigned to vmpool.

Expected results:
quota2 is assigned to pool.

Additional info:

--- Additional comment from ofri on 2013-06-03 08:32:43 EDT ---

Quota selection in the Edit dialog should have been disabled (like all of the other fields which are inherited from the template). 
The user can select the quota for the pool once (on pool creation) but cannot change the quota selection once the pool was already created.

Comment 3 errata-xmlrpc 2013-08-13 13:07:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1149.html


Note You need to log in before you can comment on or make changes to this bug.