Bug 977365 - nova: launching an instance from a volume has a very complicated syntax
nova: launching an instance from a volume has a very complicated syntax
Status: CLOSED DUPLICATE of bug 893374
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: ---
: 5.0 (RHEL 7)
Assigned To: RHOS Maint
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 07:48 EDT by Dafna Ron
Modified: 2014-09-08 01:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 10:20:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dafna Ron 2013-06-24 07:48:58 EDT
Description of problem:

if I want to run an instance from an image all I have to do is add --image <uuid> 

but running an instance from a volume uses the following

<dev_name>=<id>:<type>:<size(GB)>:<delete_on_terminate>

--block-device-mapping vda=$VOL_ID 

as in:  

# nova boot --flavor 2  --block_device_mapping=vda=<VOL_UUID>::: dafna5

I think that launching an instance from a volume should have a simple syntax (as in --volume <VOL_UUID>) and if we need more params they should be optional (

Version-Release number of selected component (if applicable):

openstack-nova-compute-2013.1.2-2.el6ost.noarch
openstack-nova-api-2013.1.2-2.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. boot an instance from an image
2. boot an instance from a volume
3.

Actual results:

--block_device_mapping=vda=<VOL_UUID>::: is complicated for booting an instance from a volume (and to be honest, if I hadn't looked at the code I would not know how to do it from the command help). 

Expected results:

booting an instance should be simple and following the same command structure logic. we should have --volume/image and any other device we can boot from in simple --<params> in the nova boot command

Additional info:

root@opens-vdsb ~(keystone_admin)]# nova boot --flavor 2  --block_device_mapping=vda=df9dc16d-c942-478e-bdc3-1e5d04a88068::: dafna5
+-------------------------------------+-------------------------------------------------+
| Property                            | Value                                           |
+-------------------------------------+-------------------------------------------------+
| OS-EXT-STS:task_state               | scheduling                                      |
| image                               | Attempt to boot from volume - no image supplied |
| OS-EXT-STS:vm_state                 | building                                        |
| OS-EXT-SRV-ATTR:instance_name       | instance-00000008                               |
| flavor                              | m1.small                                        |
| id                                  | c173508f-59c5-47db-8dde-d0ca0d07c868            |
| security_groups                     | [{u'name': u'default'}]                         |
| user_id                             | d7da5e41ae264110ae2c6d12cc97414a                |
| OS-DCF:diskConfig                   | MANUAL                                          |
| accessIPv4                          |                                                 |
| accessIPv6                          |                                                 |
| progress                            | 0                                               |
| OS-EXT-STS:power_state              | 0                                               |
| OS-EXT-AZ:availability_zone         | nova                                            |
| config_drive                        |                                                 |
| status                              | BUILD                                           |
| updated                             | 2013-06-24T11:17:08Z                            |
| hostId                              |                                                 |
| OS-EXT-SRV-ATTR:host                | None                                            |
| key_name                            | None                                            |
| OS-EXT-SRV-ATTR:hypervisor_hostname | None                                            |
| name                                | dafna5                                          |
| adminPass                           | py7JHV4ZK6t4                                    |
| tenant_id                           | 094ca07d03be4874a354ad7be034145e                |
| created                             | 2013-06-24T11:17:07Z                            |
| metadata                            | {}                                              |
+-------------------------------------+-------------------------------------------------+
[root@opens-vdsb ~(keystone_admin)]# nova list
+--------------------------------------+--------+--------+--------------------------+
| ID                                   | Name   | Status | Networks                 |
+--------------------------------------+--------+--------+--------------------------+
| 1b129b16-ccfa-4d7a-bd5c-1817edd87fdc | dafna  | ACTIVE | novanetwork=192.168.32.2 |
| 8a601418-3b80-483f-af7a-9bfb040b6b33 | dafna1 | ACTIVE | novanetwork=192.168.32.4 |
| c173508f-59c5-47db-8dde-d0ca0d07c868 | dafna5 | ACTIVE | novanetwork=192.168.32.3 |
+--------------------------------------+--------+--------+--------------------------+
Comment 1 Xavier Queralt 2013-07-31 10:20:00 EDT
Improving the nova boot interface is covered by #893374,closing as a duplicate.

*** This bug has been marked as a duplicate of bug 893374 ***

Note You need to log in before you can comment on or make changes to this bug.