Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 977371 - [REGRESSION] Can't start a concurrent virt-manager in the VNC session
Summary: [REGRESSION] Can't start a concurrent virt-manager in the VNC session
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-24 11:53 UTC by Jaromír Cápík
Modified: 2016-02-01 01:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-24 11:59:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Jaromír Cápík 2013-06-24 11:53:23 UTC
Description of problem:
Hello. In the past (IIRC in the F16) it was possible to start two concurrent virt-manager windows (and tray icons) on the physical screen and in the VNC session. One of the connections had to be "localhost(QEMU)" and the second one had to be "localhost(QEMU+ssh)" in order to avoid conflicts, but it worked well. Now it's impossible to start two concurrent virt-managers. When I do so, the virt-manager window is always opened on the screen where the tray icon is.
Please, restore the previous behaviour and allow at least two concurrent windows.

Version-Release number of selected component (if applicable):
virt-manager-0.9.5-1.fc18

How reproducible:
always

Steps to Reproduce:
1. start virt-manager on the physical screen
2. start vncserver (tigervnc-server in my case) on the same computer and connect to the newly created session as the same user ("vncviewer :1" or similar) ... the vnc xstartup script needs to be finetuned to start a different WM in order to avoid conflicts with the physical screen session (I'm using xfce4 on the physical screen and icewm in the vnc session .... note that icewm has broken skins in F18 ... "gtk2" skin seems to work well)
3. try to start virt-manager in the vnc session

Actual results:
The virt-manager window is opened on the physical screen

Expected results:
The virt-manager window is opened in the VNC session

Comment 1 Jaromír Cápík 2013-06-24 11:59:17 UTC
Sorry. Apparently this was caused by the following two missing lines in the customized xstartup script ...

unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS

Closing.


Note You need to log in before you can comment on or make changes to this bug.