Bug 977376 - HHH-8325 JavaAssist regression causing java.lang.instrument.IllegalClassFormatException
HHH-8325 JavaAssist regression causing java.lang.instrument.IllegalClassForma...
Status: CLOSED DUPLICATE of bug 900690
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brett Meyer
Depends On:
  Show dependency treegraph
Reported: 2013-06-24 08:13 EDT by Adam Kovari
Modified: 2015-09-01 00:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-06-26 23:44:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Kovari 2013-06-24 08:13:10 EDT
Description of problem:
Issues related to JavaAssist used in EAP, such as:

Caused by: java.lang.instrument.IllegalClassFormatException: Unable to transform class: cannot find com.lhsystems.lc2.domain.basicdata.md.Airport
        at org.hibernate.ejb.instrument.InterceptFieldClassFileTransformer.transform(InterceptFieldClassFileTransformer.java:79)
        at org.jboss.as.jpa.classloader.JPADelegatingClassFileTransformer.transform(JPADelegatingClassFileTransformer.java:48)
        at org.jboss.as.server.deployment.module.DelegatingClassFileTransformer.transform(DelegatingClassFileTransformer.java:60) [jboss-as-server-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
        at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:414) [jboss-modules.jar:1.2.0.Final-redhat-1]
        ... 23 more

Version-Release number of selected component (if applicable):
EAP 6.1.0
JavaAssist 6.1.0

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:
Seems to be fixed in JavaAssist 3.18 but there seem to be other problems related to Seam.
Comment 2 Brett Meyer 2013-06-26 23:44:32 EDT
Adam, I just canceled HHH-8325.  The "regression" in Javassist 3.18.0 was only a method signature change on an API, but we don't use it and are unaffected.  At this time, no other regressions are known.

We upgraded to Javassist 3.18.0 in https://hibernate.atlassian.net/browse/HHH-8288.  We'll be upgrading that under BZ-900690.  Closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 900690 ***

Note You need to log in before you can comment on or make changes to this bug.