Bug 977382 - Missing queues for JMS remote API
Missing queues for JMS remote API
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Marco Rietveld
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 08:25 EDT by Ivo Bek
Modified: 2016-09-20 01:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:07:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bpms-jms.xml (1.79 KB, text/xml)
2013-07-31 05:01 EDT, Ryan Zhang
no flags Details

  None (edit)
Description Ivo Bek 2013-06-24 08:25:24 EDT
Description of problem:

The RequestMessageBean (https://github.com/droolsjbpm/droolsjbpm-integration/blob/master/kie-remote/kie-services-remote/src/main/java/org/kie/services/remote/jms/RequestMessageBean.java) uses following queues which aren't in standalone-full.xml where I would expect them.

<jms-destinations>
      
      <!-- general session, task, response -->
      <jms-queue name="KIE.SESSION">
        <entry name="queue/KIE.SESSION.ALL" />
        <entry name="java:jboss/exported/jms/queue/KIE.SESSION" />
      </jms-queue>
      <jms-queue name="KIE.TASK">
        <entry name="queue/KIE.TASK.ALL" />
        <entry name="java:jboss/exported/jms/queue/KIE.TASK" />
      </jms-queue>
      <jms-queue name="KIE.RESPONSE">
        <entry name="queue/KIE.RESPONSE.ALL" />
        <entry name="java:jboss/exported/jms/queue/KIE.RESPONSE" />
      </jms-queue>
      
      <!-- wildcard session, task, response -->
      <jms-queue name="KIE.SESSION.#">
        <entry name="queue/KIE.SESSION" />
      </jms-queue>
      <jms-queue name="KIE.TASK.#">
        <entry name="queue/KIE.TASK" />
      </jms-queue>
      <jms-queue name="KIE.RESPONSE.#">
        <entry name="queue/KIE.RESPONSE" />
      </jms-queue>
      
</jms-destinations>

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Marco Rietveld 2013-06-26 04:35:51 EDT
Ivo, we expect users to manage jms queues themselves. 

The documentation for the REST/JMS services will include what queues users should set up. Unfortunately, this documentation has not been completed yet. 

Would it be okay to close this bug as a NOTABUG?
Comment 2 Ivo Bek 2013-06-26 10:20:24 EDT
Marco, personally I think the queues belong to the standalone-full.xml profile since it's the FULL profile. And the documentation can contain just information about them in standalone-full.xml and a user will copy the queues when he needs them in another profile but he has still the choice to start the full BPMS with all the abilities, which can offer. So, I would let the decision on PM what they prefer.
Comment 3 Marco Rietveld 2013-06-28 11:00:17 EDT
Hi Ivo, that seems like a reasonable request. I've started talking to Julian and Doug about how the B*MS servers are configured and made them aware that the queues need to be created. 

Unfortunately, they are still in the process of creating the (server configuration) component that would create these JMS queues. Once that component has been created (in a couple weeks?), I'll let you know.
Comment 7 Ryan Zhang 2013-07-31 05:01:05 EDT
Created attachment 781020 [details]
bpms-jms.xml
Comment 8 Marco Rietveld 2013-08-01 07:23:46 EDT
Fixed with the following commit on the 6.0.x branch of the kie-wb-distributions repository: 

https://github.com/droolsjbpm/kie-wb-distributions/commit/2bd914024f7e8bd8ecd04ac10bb1548a78c0e983
Comment 9 Marek Baluch 2013-09-05 06:01:16 EDT
Verified on ER2.

Note You need to log in before you can comment on or make changes to this bug.