Bug 9774 - /var/yp/Makefile is corrupted
Summary: /var/yp/Makefile is corrupted
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ypserv   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-25 04:48 UTC by sauron
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-04 20:45:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sauron 2000-02-25 04:48:20 UTC
Package: ypserv
Version: 1.3.7-3

Despite the comments in the package, some of the invocations of awk
in the Makefile (mentioned in the subject) are preceded by '@'.  This
causes maps not to be built.
Some of the instances were fixed.  Specifically, the invocation of awk
in the rules for creating 'passwd' maps.  So, at the first glance it may
appear that NIS is working.  But the invocation of awk in the make rules
for
the second most important map (in my humble opinion) -- "group" -- were
not fixed.  That is how I discovered this bug in the first place.

Comment 1 Cristian Gafton 2000-03-04 18:28:59 UTC
The @ in fornt of a command in a Makefile tells make not to echo the command
itself to stdout. It has nothing to do with whether the command is executed or
not, because the command is always executed. Check again your Makefile to make
sure that MERGE_GROUP is defined as you need to.

Comment 2 sauron 2000-03-04 19:49:59 UTC
I am sorry to have to be argumentative, but that is not entirely correct.  make
only interprets '@' character if it appears at the beginning of a line as long
as that line is not a continuation of another line.
Example:

Contents of Makefile:

all:
    @echo line 1
    @echo line 2; \
    @echo line 3


$ make
line 1
line 2
/bin/sh: @echo: command not found
make: *** [all] Error 127

Some of the lines in yp Makefile that contain awk calls do follow lines that
end with a backslash.  So the make does not interpret '@' character in them
as intended.

Comment 3 Cristian Gafton 2000-03-04 20:44:59 UTC
I double checked again  - this has been fixed in the devel tree

Comment 4 sauron 2000-03-04 20:45:59 UTC
Great!


Note You need to log in before you can comment on or make changes to this bug.