Bug 977413 - named: "PID file has been moved to /run/named/named.pid" should be documented
named: "PID file has been moved to /run/named/named.pid" should be documented
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Pete Travis
Tomáš Hozza
:
: 977191 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 09:45 EDT by Tomáš Hozza
Modified: 2013-12-09 10:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
In Red Hat Enterprise Linux 7.0 Beta, the "named" PID file has been moved from the BIND default location /var/run/named/named.pid to the new location /run/named/named.pid. In addition, the "session-key" file has been moved to /run/named/session.key. These locations need to be specified by statements in the "options" section of the BIND configuration: options { ... pid-file "/run/named/named.pid"; session-keyfile "/run/named/session.key"; ... };
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 12:04:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Hozza 2013-06-24 09:45:00 EDT
Description of problem:
Since F19 the named PID file has been moved from default location
(/var/run/named/named.pid) to new location (/run/named/named.pid).

If someone is using custom named.conf based on older Fedora (before F19),
then they need to add a pid-file statement into options section to point
to the new PID file location.

options {
	...
	pid-file	"/run/named/named.pid";
	...
};

Version-Release number of selected component (if applicable):
Fedora 19

Actual results:
No documentation.

Expected results:
Release note informing about this change or it should be somewhere documented.

Additional info:
There is already F19 Bug #977191 cased by not informed user. Sorry for the late
Bug. The change was made by previous maintainer and I'm not aware of any
existing note warning about this.
Comment 1 Tomáš Hozza 2013-06-24 10:04:07 EDT
*** Bug 977191 has been marked as a duplicate of this bug. ***
Comment 4 Pete Travis 2013-06-26 10:38:58 EDT
Thanks, Tomas! I've added this to the Release Notes[1] and it has also been noted in the System Administrator's Guide[2]

[1] https://git.fedorahosted.org/cgit/docs/release-notes.git/commit/?h=f19&id=60bbc28b188713529d9a7c738c6d643492f83776

[2] https://git.fedorahosted.org/cgit/docs/system-administrators-guide.git/commit/?id=cd32cbeac0d7b30f8cdbdef82e820591124d29b7
Comment 5 Tomáš Hozza 2013-06-26 11:20:35 EDT
(In reply to Pete Travis from comment #4)
> Thanks, Tomas! I've added this to the Release Notes[1] and it has also been
> noted in the System Administrator's Guide[2]
> 
> [1]
> https://git.fedorahosted.org/cgit/docs/release-notes.git/commit/
> ?h=f19&id=60bbc28b188713529d9a7c738c6d643492f83776
> 
> [2]
> https://git.fedorahosted.org/cgit/docs/system-administrators-guide.git/
> commit/?id=cd32cbeac0d7b30f8cdbdef82e820591124d29b7

Looks good.

Thanks a lot!
Comment 6 Pete Travis 2013-12-09 10:43:42 EST
Lenka, please open new bugs for RHEL issues. One bug for the same issue and multiple products will make things difficult to track for all of us.

Note You need to log in before you can comment on or make changes to this bug.