Bug 97742 - (RADEON IGP)System hangs during start of pcmcia service on Presario 2140US
(RADEON IGP)System hangs during start of pcmcia service on Presario 2140US
Status: CLOSED DUPLICATE of bug 91889
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-19 20:14 EDT by Christopher Johnson
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Johnson 2003-06-19 20:14:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Installed RedHat 9 on Compaq Presario 2140US.  When booting the system hangs
during start of the pcmcia service.  There appears to be a problem  reassigning
the irq for the cardbus controller, and some other resource conflict.  If the
built-in ethernet is not started then the pcmcia service does not hang, but
doesn't recognize card presence or insertion either.

lspci -v
00:00.0 Host bridge: ATI Technologies Inc: Unknown device cab0 (rev 13)
        Flags: bus master, 66Mhz, medium devsel, latency 32
        Memory at d4000000 (32-bit, prefetchable) [size=64M]
        Memory at d0500000 (32-bit, prefetchable) [size=4K]
        I/O ports at 8090 [disabled] [size=4]
        Capabilities: [a0] AGP version 2.0
 
00:01.0 PCI bridge: ATI Technologies Inc U1/A3 AGP Bridge [IGP 320M] (rev 01)
(prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 99
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=68
        I/O behind bridge: 00009000-00009fff
        Memory behind bridge: d0100000-d01fffff
        Prefetchable memory behind bridge: e0000000-efffffff
 
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03) (prog-if 10
[OHCI])
        Subsystem: Hewlett-Packard Company: Unknown device 0024
        Flags: bus master, medium devsel, latency 64, IRQ 9
        Memory at d0000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [60] Power Management version 2
 
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 02)
        Subsystem: Hewlett-Packard Company: Unknown device 0024
        Flags: bus master, medium devsel, latency 64, IRQ 5
        I/O ports at 8400 [size=256]
        Memory at d0001000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 2
 
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
        Subsystem: ALi Corporation ALI M1533 Aladdin IV ISA Bridge
        Flags: bus master, medium devsel, latency 0
        Capabilities: [a0] Power Management version 1
 
00:08.0 Modem: ALi Corporation Intel 537 [M5457 AC-Link Modem] (prog-if 00
[Generic])
        Subsystem: Hewlett-Packard Company: Unknown device 0024
        Flags: medium devsel, IRQ 3
        Memory at d0002000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at 8800 [size=256]
        Capabilities: [40] Power Management version 2
 
00:0a.0 CardBus bridge: O2 Micro, Inc. OZ6912 Cardbus Controller
        Subsystem: Hewlett-Packard Company: Unknown device 0024
        Flags: bus master, slow devsel, latency 32, IRQ 5
        Memory at 80000000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=00, secondary=02, subordinate=05, sec-latency=32
        Memory window 0: 81000000-81100000
        I/O window 0: 00003000-0000307f
        I/O window 1: 00000000-00000003
        16-bit legacy interface ports at 0001
 
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4) (prog-if b0)
        Subsystem: Hewlett-Packard Company: Unknown device 0024
        Flags: bus master, medium devsel, latency 32
        I/O ports at 8080 [size=16]
        Capabilities: [60] Power Management version 2
 
00:11.0 Bridge: ALi Corporation M7101 PMU
        Subsystem: Hewlett-Packard Company: Unknown device 0024
        Flags: medium devsel
 
00:12.0 Ethernet controller: National Semiconductor Corporation DP83815
(MacPhyter) Ethernet Controller
        Subsystem: Hewlett-Packard Company: Unknown device 0024
        Flags: bus master, medium devsel, latency 90, IRQ 11
        I/O ports at 8c00 [size=256]
        Memory at d0003000 (32-bit, non-prefetchable) [size=4K]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [40] Power Management version 2
 
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1
(prog-if 00 [VGA])Jun  5 14:25:27 danielle kernel: Linux Kernel Card Services 3.1.22
Jun  5 14:25:27 danielle kernel:   options:  [pci] [cardbus] [pm]
Jun  5 14:25:27 danielle kernel: PCI: Found IRQ 11 for device 00:0a.0
Jun  5 14:25:27 danielle kernel: IRQ routing conflict for 00:0a.0, have irq 5,
want irq 11
Jun  5 14:25:27 danielle kernel: Yenta IRQ list 0c98, PCI irq5
Jun  5 14:25:27 danielle kernel: Socket status: 30000007
Jun  5 14:25:27 danielle cardmgr[2039]: starting, version is 3.1.31
Jun  5 14:25:27 danielle cardmgr[2039]: watching 1 sockets
Jun  5 14:25:27 danielle cardmgr[2039]: Card Services release does not match
Jun  5 14:25:27 danielle kernel: cs: IO port probe 0x0c00-0x0cff: clean.
Jun  5 14:25:27 danielle kernel: cs: IO port probe 0x0100-0x04ff: excluding
0x3c0-0x3df 0x408-0x40f 0x480-0x48f 0x4d0-0x4d7
Jun  5 14:25:27 danielle kernel: cs: IO port probe 0x0a00-0x0aff: clean.

        Subsystem: Hewlett-Packard Company: Unknown device 0024
        Flags: bus master, stepping, fast Back2Back, 66Mhz, medium devsel,
latency 66, IRQ 10
        Memory at e0000000 (32-bit, prefetchable) [size=256M]
        I/O ports at 9000 [size=256]
        Memory at d0100000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2
 
Syslog excerpt from starting pcmcia if ethernet was not started:




Version-Release number of selected component (if applicable):
kernel-2.4.20-18.9

How reproducible:
Always

Steps to Reproduce:
1.Install RH9 (any kernel up through 2.4.20-18.9) on Presario 2140US
2.Boot system
3.
    

Actual Results:  If ethernet cable is connected the system hangs during start of
pcmcia service just after "OK"
If ethernet cable is not connected system boots but pcmcia cards might as well
not exist.  There is no indication in log or otherwise that there are any cards.

Expected Results:  System boots normally regardless of ethernet connection.
pcmcia cards are seen and if supported they work normally.

Additional info:
I tried building a custom 2.4.20-18.9 kernel using redhat's 
kernel-source-2.4.20-18.9 starting with standard athlon config but turning on
ACPI features.  With this kernel power conserving use of the cpu happens (fan
actually cycles off!) and power-off at shutdown works, but the pcmcia issues
remain the same.
Comment 1 Alan Cox 2003-06-22 14:29:59 EDT

*** This bug has been marked as a duplicate of 91889 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:56:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.