Bug 977433 - Please rename 'nm_dispatcher.service' to 'NetworkManager-dispatcher.service' in 90-default.preset
Please rename 'nm_dispatcher.service' to 'NetworkManager-dispatcher.service' ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
: 978026 (view as bug list)
Depends On:
Blocks: 974811
  Show dependency treegraph
 
Reported: 2013-06-24 10:26 EDT by Jirka Klimes
Modified: 2016-01-04 01:03 EST (History)
11 users (show)

See Also:
Fixed In Version: systemd-204-9.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 20:23:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jirka Klimes 2013-06-24 10:26:36 EDT
NetworkManager dispatcher file has been renamed from nm_dispatcher.service to NetworkManager-dispatcher.service (in NetworkManager-0.9.8.2-1.fc19).

However, the new name is not present in the default Fedora preset policy and thus the NM dispatcher is not enabled on upgrade. This result in errors, like bug 974811.
Comment 1 Jirka Klimes 2013-06-24 10:28:30 EDT
Filed this bug as suggested in http://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd.
Comment 2 Jóhann B. Guðmundsson 2013-06-24 10:37:30 EDT
Re-assigning to correct component...
Comment 3 Jóhann B. Guðmundsson 2013-06-24 10:41:22 EDT
Whoops this was not the triggered file not found dbus error that came with that those moving back.

My bad.
Comment 4 Fedora Update System 2013-06-24 11:39:16 EDT
systemd-204-9.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/systemd-204-9.fc19
Comment 5 Fedora Update System 2013-06-25 17:16:40 EDT
Package systemd-204-9.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-204-9.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11662/systemd-204-9.fc19
then log in and leave karma (feedback).
Comment 6 Michal Schmidt 2013-06-26 04:05:01 EDT
*** Bug 978026 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2013-07-01 20:23:24 EDT
systemd-204-9.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.