Bug 977434 - [vdsm] vdsm does not support engine versions 3.2 and 3.3
[vdsm] vdsm does not support engine versions 3.2 and 3.3
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Unspecified
high Severity urgent
: ---
: 3.3.0
Assigned To: Mooli Tayer
Barak Dagan
infra
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 10:30 EDT by Elad
Modified: 2016-02-10 14:13 EST (History)
12 users (show)

See Also:
Fixed In Version: is8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:08:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elad 2013-06-24 10:30:49 EDT
Description of problem:
vdsm version 4.11 does not support engine versions that are higher than 3.1:



[root@green-vdsb ~]# vdsClient -s 0 getVdsCaps |grep supportedENGINEs
        supportedENGINEs = ['3.0', '3.1']


/usr/share/vdsm/dsaversion.py :

version_info = {
    'version_name': version_name,
    'software_version': software_version,
    'software_revision': software_revision,
    'supportedENGINEs': ['3.0', '3.1'],
    'supportedProtocols': ['2.2', '2.3'],
    'clusterLevels': ['3.0', '3.1', '3.2', '3.3'],




Version-Release number of selected component (if applicable):
vdsm-4.11


Expected results:
vdsm should support all engine versions
Comment 1 Itamar Heim 2013-06-25 02:13:22 EDT
actually this was fixed already with:
http://gerrit.ovirt.org/#/c/15663/
http://gerrit.ovirt.org/#/c/15675/

*but* iirc we also need supportedRHEVMs for RHEV-M 3.0 / backward compatibility downstream?
Comment 2 Mooli Tayer 2013-07-14 10:31:50 EDT
the variable named "supportedRHEVMs" was renamed to "supportedENGINEs":
http://gerrit.ovirt.org/#/c/8661/

Looking at the history of VdsProperties.java  it appears 'supportedENGINEs' was always expected as described in the above gerrit
Comment 3 Itamar Heim 2013-07-14 16:03:16 EDT
Mooli - how does this resolve my comment 1?
Comment 12 Mooli Tayer 2013-10-31 11:25:53 EDT
Can you please provide info on why we cannot see this commit http://gerrit.ovirt.org/#/c/15675/ downstream?
Comment 14 Barak Dagan 2013-10-31 11:53:39 EDT
It was supposed to be merged in is8, but wasn't merged, apparently, in is14.
re-verified on IS20.1

/usr/share/vdsm/dsaversion.py 

version_name = "Snow Man"
# FIXME: As soon as we can provide a long version/release to oVirt-Engine
#        remove from vdsm.spec the sed to replace the below macros
software_version = "4.13"
software_revision = "0.5"
raw_version_revision = "4.13.0-0.5.beta1.el6ev"

version_info = {
    'version_name': version_name,
    'software_version': software_version,
    'software_revision': software_revision,
    'supportedENGINEs': ['3.0', '3.1', '3.2', '3.3'],
    'supportedRHEVMs': ['3.0'],
    'supportedProtocols': ['2.2', '2.3'],
    'clusterLevels': ['3.0', '3.1', '3.2', '3.3'],


# vdsClient -s 0 getVdsCaps |grep supportedENGINEs
	supportedENGINEs = ['3.0', '3.1', '3.2', '3.3']
Comment 15 Charlie 2013-11-27 19:28:18 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 16 errata-xmlrpc 2014-01-21 11:08:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.