Bug 977440 - Share the engine's os info with DWH through a translation table
Share the engine's os info with DWH through a translation table
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Roy Golan
Ilanit Stein
virt
:
Depends On:
Blocks: 985346 1019461
  Show dependency treegraph
 
Reported: 2013-06-24 10:37 EDT by Roy Golan
Modified: 2015-09-22 09 EDT (History)
12 users (show)

See Also:
Fixed In Version: is15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 985346 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17767 None None None Never

  None (edit)
Description Roy Golan 2013-06-24 10:37:37 EDT
Description of problem:
in 3.3 we adding the ability to add user-defined OSs to the engine.
Reports on vm os type will end with up with new entries without the actual name of the OS, as kept in the engine.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
DWH keeps its own translation based on the VmOsType enum and won't have any info
on new OSs

Expected results:
DWH will be able to read the mapping from the engine db. The data will relay in 
a dedicated dwh_osinfo table.

Additional info:
Comment 1 Yaniv Lavi (Dary) 2013-06-25 08:59:58 EDT
This is a documentation bug. We need to add a guide to adding new OSs to the history database. Zac, which component to move this to? 



Yaniv
Comment 2 Roy Golan 2013-07-17 06:32:31 EDT
resetting this bug to the engine
Yaniv I cloned one for the DWH
Comment 3 Itamar Heim 2013-07-18 00:37:21 EDT
what happens if user adds an OS, then removes it?
or adds an OS, then removes it, then adds another OS with same ID?
how will localization be handled?
do we even support using OsInfo by customers in 3.3 before we used it ourselves for a version and are sure we thought through all the upgrade issues on customer changes?
Comment 4 Barak 2013-08-01 09:03:42 EDT
A short explanation about this issue:

Since in 3.3 a customer can add a guest OS on his own,
And the list is currently is hardcoded in the history DB, than we need a mechanism to collect the other guest OSs.

It needs to be dynamic.

So there are 2 bugs:
- this virt bug - that is on the backend that should create a table (dwh_osinfo) that needs to be refreshed every engine restart.
- Bug  985346 (on dwh) - to collect data from the dwh_osinfo (only on refresh)

Hence moving this bug back to virt.
Comment 5 Yaniv Lavi (Dary) 2013-09-09 16:31:03 EDT
Please provide status update.


Yaniv
Comment 6 Roy Golan 2013-09-11 02:34:03 EDT
Yaniv its pending long ago your review in gerrit, after the comment to add an entry in dwh_history_timekeeping
Comment 7 Zac Dover 2013-09-24 01:13:32 EDT
(In reply to Yaniv Dary from comment #1)
> This is a documentation bug. We need to add a guide to adding new OSs to the
> history database. Zac, which component to move this to? 
> 
> 
> 
> Yaniv

I am sorry about the extreme lateness of this reply; it bypassed my inbox entirely.

This bug impacts http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Enterprise_Virtualization/3.2/html/Administration_Guide/chap-Reports_History_Database_Reports_and_Dashboards.html, to begin with.

If we want to add a section detailing how to add a new OS to the history database, I'll need more information about the feature before I can determine which book it should be added to.
Comment 8 Ilanit Stein 2013-09-24 04:57:31 EDT
Verified on is15.


Added this entry in a new .properties file under /etc/ovirt-engine/osinfo.conf.d:

os.ilanit.id.value = 2000
os.ilanit.name.value = Ilanit
os.ilanit.derivedFrom.value = other
os.ilanit.description.value = General user defined OS
os.ilanit.family.value = user defined
os.ilanit.devices.audio.value = ac97
Comment 9 Itamar Heim 2014-01-21 17:22:53 EST
Closing - RHEV 3.3 Released
Comment 10 Itamar Heim 2014-01-21 17:24:02 EST
Closing - RHEV 3.3 Released
Comment 11 Itamar Heim 2014-01-21 17:27:48 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.