Bug 977456 - Timeout during cartridge migrations breaks reentrancy
Timeout during cartridge migrations breaks reentrancy
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 11:18 EDT by Paul Morie
Modified: 2015-05-14 19:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:54:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Morie 2013-06-24 11:18:56 EDT
Currently, if the cartridge migration times out after the version of a cartridge is updated (or anything else goes wrong that fails the migration), re-entrancy is broken.  What the means is that although the migration hasn't finished, the need to continue migrating will not be detected.
Comment 1 Paul Morie 2013-07-26 12:50:21 EDT
Fix available in master now.
Comment 2 Jianwei Hou 2013-07-30 01:28:45 EDT
Verified on devenv_3580

Steps:
1. Create a diy application, edit its 'start' action hook, add 'sleep 600'.
2. Migrate all gears on node 
oo-admin-upgrade --version 2.0.31 --ignore-cartridge-version 

During migration, noticed that the target app failed to migrate due to timeout problem.
3. Fix the app and migrate with --rerun option
oo-admin-upgrade --version 2.0.31 --ignore-cartridge-version --rerun

The migrator only pick up the failed gear and migrated it successfully.

Mark as verified.

Note You need to log in before you can comment on or make changes to this bug.