Bug 977480 - v1.4.0 released upstream
v1.4.0 released upstream
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dtc (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Arnd Bergmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 12:21 EDT by Stephen Warren
Modified: 2013-11-27 16:19 EST (History)
3 users (show)

See Also:
Fixed In Version: dtc-1.4.0-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-06 21:36:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Warren 2013-06-24 12:21:01 EDT
dtc v1.4.0 has been tagged/released at git://git.jdl.com/software/dtc.git. It'd be great if this could be packaged up for as many Fedora releases as possible.

This version brings a slew of new features, some of which:

* Are already required for some *.dts files in the Linux kernel.
* Will soon be required for the *.dts files in U-Boot.
Comment 1 Stephen Warren 2013-06-24 12:23:49 EDT
I guess this should be updated in EPEL as well, since core RHEL doesn't seem to package this. Is this bug sufficient, or should I file a separate one for that?
Comment 2 Josh Boyer 2013-06-24 13:06:38 EDT
OK.  I'll look at this later today.  FWIW, F19 and rawhide are carrying a git snapshot of the commit before 1.4 was tagged.

(In reply to Stephen Warren from comment #1)
> I guess this should be updated in EPEL as well, since core RHEL doesn't seem
> to package this. Is this bug sufficient, or should I file a separate one for
> that?

I've CC'd the EPEL maintainer.  He'll be able to just use this.
Comment 3 Stephen Warren 2013-06-24 13:22:22 EDT
Thanks for the update.

Just as background info: One benefit of taking the actual git commit that bumped the version number is that applications/scripts that use dtc can tell just from the version number whether the new features are available. The U-Boot build process is likely (in the near future) to take a patch that relies on this.
Comment 4 Josh Boyer 2013-06-24 13:32:11 EDT
(In reply to Stephen Warren from comment #3)
> Thanks for the update.
> 
> Just as background info: One benefit of taking the actual git commit that
> bumped the version number is that applications/scripts that use dtc can tell
> just from the version number whether the new features are available. The
> U-Boot build process is likely (in the near future) to take a patch that
> relies on this.

Yeah, that's certainly better.  We only grabbed the git snapshot as a fix for installing libfdt_env.h anyway.
Comment 5 Josh Boyer 2013-06-24 14:50:13 EDT
OK, this is updated in the F18-rawhide branches and builds are done for those branches as well.  I'll file updates for the releases in a bit.
Comment 6 Fedora Update System 2013-06-24 15:49:46 EDT
dtc-1.4.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dtc-1.4.0-1.fc19
Comment 7 Fedora Update System 2013-06-24 15:51:10 EDT
dtc-1.4.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dtc-1.4.0-1.fc18
Comment 8 Fedora Update System 2013-06-25 17:16:18 EDT
Package dtc-1.4.0-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dtc-1.4.0-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11656/dtc-1.4.0-1.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-06-26 07:54:46 EDT
dtc-1.4.0-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/dtc-1.4.0-1.el6
Comment 10 Fedora Update System 2013-07-06 21:36:27 EDT
dtc-1.4.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-07-06 21:36:40 EDT
dtc-1.4.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-11-27 16:19:37 EST
dtc-1.4.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.