Bug 977502 - The deployment of KPI's and Workspaces using import/export has issues
The deployment of KPI's and Workspaces using import/export has issues
Status: CLOSED WORKSFORME
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Dashboard Builder (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Van Halbert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 14:04 EDT by Van Halbert
Modified: 2014-07-31 16:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The import of KPIs and workspaces is not yet supported in JBoss Dashboard Builder. The following workaround is suggested: 1.- Export your target dashboard (.cex zip file containing an XML file with the workspace structure) -> MyWorkspace.xml 2.- Export your target KPIs (XML file containing all the KPIs referenced by your dashboard(s)) -> MyKPIs.xml 3.- Create a MyDashboardSampleBuider class which will deploy the previous assets on start-up. You could use the current TeiidShowcaseBuilder.java and update it. 4.- Rebuild the .war and then deploy.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-31 16:50:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Van Halbert 2014-07-31 16:50:08 EDT
Building an example to show the Teiid Command and Auditing logging, and I don't see an issue with exporting/importing in order to configure the example.  Therefore, I'm closing this as it works for me.

Note You need to log in before you can comment on or make changes to this bug.