Bug 97754 - ntpd can't open/etc/ntp/drift.TEMP
Summary: ntpd can't open/etc/ntp/drift.TEMP
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ntp (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-20 13:23 UTC by Jonathan Kamens
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version: ntp-4.1.2-1.rc3.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-27 10:18:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2003-06-20 13:23:39 UTC
I have ntp-4.1.2-1.rc3.2.  I keep seeing this in my syslog:

Jun 20 02:46:01 jik ntpd[635]: can't open /etc/ntp/drift.TEMP: Permission denied

This makes sense, since ntpd is running as ntp/ntp and the directory is owned 
by root/root.

It looks like when opening the TEMP file fails it falls back on writing 
directly to /etc/ntp/drift, so all is not lost; still, if it wants to write to 
a TEMP file, then the RPM should probably be shipped with permissions that 
allow that.


Note You need to log in before you can comment on or make changes to this bug.