Bug 977555 - dnsmasq: failed to set SO_REUSE{ADDR|PORT} on DHCP socket: Protocol not available
dnsmasq: failed to set SO_REUSE{ADDR|PORT} on DHCP socket: Protocol not avail...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnsmasq (Show other bugs)
18
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tomáš Hozza
Fedora Extras Quality Assurance
:
Depends On: 950755
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 18:00 EDT by Suren Karapetyan
Modified: 2013-08-03 20:03 EDT (History)
16 users (show)

See Also:
Fixed In Version: dnsmasq-2.65-7.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 950755
Environment:
Last Closed: 2013-08-03 20:03:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suren Karapetyan 2013-06-24 18:00:31 EDT
+++ This bug was initially created as a clone of Bug #950755 +++

Description of problem:
Libvirt fails to start virtual networks with DHCP enabled.

Version-Release number of selected component (if applicable): dnsmasq-2.65-6.fc18.x86_64

How reproducible:
Always

Steps to Reproduce:
1.  Start libvirtd with default config.
  
Actual results:
"default" virtual network doesn't start

Expected results:
"default" virtual network starts

More info:
rebuilding the dnsmasq-2.66-3.fc19 src.rpm for fc18 does indeed fix the problem for me. Can we please have it built and pushed to stable?

--- Additional comment from Jiri Denemark on 2013-04-12 05:30:54 EDT ---

As far as I know, this should be fixed in dnsmasq-2.66rc5

--- Additional comment from Fedora Update System on 2013-04-12 06:08:20 EDT ---

dnsmasq-2.66-1.rc5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dnsmasq-2.66-1.rc5.fc19

--- Additional comment from Fedora Update System on 2013-04-18 13:24:33 EDT ---

Package dnsmasq-2.66-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnsmasq-2.66-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5540/dnsmasq-2.66-2.fc19
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2013-04-22 13:19:49 EDT ---

Package dnsmasq-2.66-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnsmasq-2.66-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5540/dnsmasq-2.66-3.fc19
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2013-05-03 21:46:06 EDT ---

dnsmasq-2.66-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from Suren Karapetyan on 2013-06-24 03:13:57 EDT ---

Can we have this fixed on Fedora 18?

--- Additional comment from Tomas Hozza on 2013-06-24 03:19:04 EDT ---

(In reply to Suren Karapetyan from comment #6)
> Can we have this fixed on Fedora 18?

Sure, can you please create F18 Bug? Thanks!
Comment 1 Derek Higgins 2013-07-16 07:51:47 EDT
+1 to fixing this, I started hitting it today on F18 (looks like its ever since dnsmasq-2.65-6.fc18 was push to updates)
Comment 2 Tomáš Hozza 2013-07-16 09:40:46 EDT
Can you please test the following build?

http://koji.fedoraproject.org/koji/taskinfo?taskID=5612726

Thanks!
Comment 3 Derek Higgins 2013-07-16 20:08:29 EDT
works for me
Comment 4 Fedora Update System 2013-07-17 02:39:28 EDT
dnsmasq-2.65-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dnsmasq-2.65-7.fc18
Comment 5 Fedora Update System 2013-07-18 02:04:37 EDT
Package dnsmasq-2.65-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnsmasq-2.65-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13204/dnsmasq-2.65-7.fc18
then log in and leave karma (feedback).
Comment 6 Peter Larsen 2013-07-21 09:59:44 EDT
Had the exact same problem - the updates-testing does fix it. Thanks for fixing this so quickly!
Comment 7 Fedora Update System 2013-08-03 20:03:59 EDT
dnsmasq-2.65-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.