Bug 977558 - [abrt] WARNING: at lib/dma-debug.c:950 check_for_stack+0xa0/0x100()
[abrt] WARNING: at lib/dma-debug.c:950 check_for_stack+0xa0/0x100()
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:786077f5a53e9d406293f564b92...
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 18:41 EDT by Andy Lawrence
Modified: 2015-02-19 11:30 EST (History)
9 users (show)

See Also:
Fixed In Version: kernel-3.9.9-201.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-19 11:29:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (56.91 KB, text/plain)
2013-06-24 18:41 EDT, Andy Lawrence
no flags Details
ath3k_fix_dma_on_stack.patch (1.44 KB, text/plain)
2013-06-26 09:53 EDT, Stanislaw Gruszka
no flags Details
Most recent dmesg for error (69.66 KB, text/plain)
2014-07-04 11:50 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description Andy Lawrence 2013-06-24 18:41:36 EDT
Description of problem:
happened on boot

Additional info:
reporter:       libreport-2.1.5
WARNING: at lib/dma-debug.c:950 check_for_stack+0xa0/0x100()
ehci-pci 0000:00:1a.0: DMA-API: device driver maps memory fromstack [addr=ffff8800a6a47a4f]
Modules linked in: ath3k(+) videodev(+) mii media option(+) microcode(+) usb_wwan btusb ath9k(+) bluetooth ath9k_common snd_hda_codec_hdmi ath9k_hw ath snd_hda_codec_ca0132 snd_hda_intel(+) mac80211 snd_hda_codec snd_hwdep cfg80211 snd_seq snd_seq_device rfkill snd_pcm lpc_ich i2c_i801 mfd_core snd_page_alloc snd_timer snd soundcore binfmt_misc uinput i915 i2c_algo_bit drm_kms_helper drm i2c_core video
CPU: 2 PID: 241 Comm: systemd-udevd Not tainted 3.10.0-0.rc6.git0.4.fc20.x86_64 #1
Hardware name: GOOGLE Link, BIOS          12/10/2012
 0000000000000009 ffff8800a6a47708 ffffffff817170dc ffff8800a6a47740
 ffffffff81067571 ffff8800a7c4b470 ffff8800a785f6d8 ffff8800a6a47a4f
 ffff8800a7c4b470 ffffffff81c19a40 ffff8800a6a477a0 ffffffff810675dc
Call Trace:
 [<ffffffff817170dc>] dump_stack+0x19/0x1b
 [<ffffffff81067571>] warn_slowpath_common+0x61/0x80
 [<ffffffff810675dc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff813775a0>] check_for_stack+0xa0/0x100
 [<ffffffff81377940>] debug_dma_map_page+0x100/0x140
 [<ffffffff814ef080>] usb_hcd_map_urb_for_dma+0x5d0/0x700
 [<ffffffff814ef445>] usb_hcd_submit_urb+0x295/0x8d0
 [<ffffffff810d6c6c>] ? lockdep_init_map+0xac/0x4a0
 [<ffffffff814f0a65>] usb_submit_urb+0x155/0x3d0
 [<ffffffff814f1474>] usb_start_wait_urb+0x74/0x190
 [<ffffffff811be003>] ? kmem_cache_alloc_trace+0x113/0x360
 [<ffffffff814f1655>] usb_control_msg+0xc5/0x110
 [<ffffffff8101fd69>] ? sched_clock+0x9/0x10
 [<ffffffffa04c7042>] ath3k_get_state+0x42/0x50 [ath3k]
microcode: CPU1 sig=0x306a9, pf=0x10, revision=0x12
 [<ffffffffa04c7307>] ath3k_load_patch+0x97/0x280 [ath3k]
 [<ffffffffa04c776f>] ath3k_probe+0x6f/0x44c [ath3k]
 [<ffffffff810d964d>] ? trace_hardirqs_on+0xd/0x10
 [<ffffffff814f59af>] usb_probe_interface+0x1cf/0x300
 [<ffffffff8146b237>] driver_probe_device+0x87/0x390
 [<ffffffff8146b613>] __driver_attach+0x93/0xa0
 [<ffffffff8146b580>] ? __device_attach+0x40/0x40
 [<ffffffff81469153>] bus_for_each_dev+0x63/0xa0
 [<ffffffff8146ac6e>] driver_attach+0x1e/0x20
 [<ffffffff8146a800>] bus_add_driver+0x1f0/0x2a0
 [<ffffffff8146bc91>] driver_register+0x71/0x150
 [<ffffffff814f4157>] usb_register_driver+0xa7/0x190
 [<ffffffffa014b000>] ? 0xffffffffa014afff
 [<ffffffffa014b01e>] ath3k_driver_init+0x1e/0x1000 [ath3k]
 [<ffffffff810020e2>] do_one_initcall+0xe2/0x1a0
 [<ffffffff810ea4e1>] load_module+0x21c1/0x2870
 [<ffffffff81376470>] ? ddebug_proc_write+0xf0/0xf0
 [<ffffffff810ead26>] SyS_finit_module+0x86/0xb0
 [<ffffffff81728b19>] system_call_fastpath+0x16/0x1b
Comment 1 Andy Lawrence 2013-06-24 18:41:43 EDT
Created attachment 764797 [details]
File: dmesg
Comment 2 Josh Boyer 2013-06-25 07:59:28 EDT
Seems the ath3k driver is misusing the DMA-API.
Comment 3 Stanislaw Gruszka 2013-06-26 09:53:43 EDT
Created attachment 765610 [details]
ath3k_fix_dma_on_stack.patch

Proposed fix for this bug. Please test, I started test kernel build here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5546257
Comment 4 Andy Lawrence 2013-06-26 12:42:29 EDT
Fix confirmed, thank you my friend!
Comment 5 Stanislaw Gruszka 2013-06-27 05:49:44 EDT
Posted patch here:
http://marc.info/?l=linux-bluetooth&m=137232637722368&w=2
Josh, please apply it as fix for this bug.
Comment 6 Josh Boyer 2013-06-27 09:37:43 EDT
Fixed on all branches.  Thanks!
Comment 7 Fedora Update System 2013-06-27 18:09:52 EDT
kernel-3.9.8-100.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2013-9123/kernel-3.9.8-100.fc17
Comment 8 Fedora Update System 2013-06-27 18:15:32 EDT
kernel-3.9.8-300.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.9.8-300.fc19
Comment 9 Fedora Update System 2013-06-29 11:24:54 EDT
Package kernel-3.9.8-300.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.9.8-300.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11901/kernel-3.9.8-300.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-06-29 12:07:55 EDT
kernel-3.9.8-200.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.9.8-200.fc18
Comment 11 Fedora Update System 2013-06-30 21:30:29 EDT
kernel-3.9.8-100.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-06-30 21:40:06 EDT
kernel-3.9.8-300.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-07-05 15:04:29 EDT
kernel-3.9.9-201.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.9.9-201.fc18
Comment 14 Fedora Update System 2013-07-11 23:10:29 EDT
kernel-3.9.9-201.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 D. Charles Pyle 2014-07-04 11:30:43 EDT
Happening again in USB Storage driver in kernel 3.16.0 series.

ABRT refuses to open another bug because it refers the user here but this error is frequent and happens several times a session at times. I am seeing this daily, now.

WARNING: CPU: 1 PID: 269 at lib/dma-debug.c:1153 check_for_stack+0x92/0xe0()
ehci-pci 0000:00:1a.7: DMA-API: device driver maps memory fromstack [addr=ffff880036c7fd68]
Modules linked in: btrfs xor raid6_pq radeon i2c_algo_bit drm_kms_helper ttm uas drm r8169 mii i2c_core usb_storage
CPU: 1 PID: 269 Comm: usb-storage Not tainted 3.16.0-0.rc3.git2.1.fc21.x86_64 #1
Hardware name: Dell Inc. Inspiron 560  /018D1Y, BIOS A06     12/01/2010
 0000000000000000 0000000047307cd4 ffff880036c7f978 ffffffff81807dac
 ffff880036c7f9c0 ffff880036c7f9b0 ffffffff8109b3ed ffff880036c7fd68
 ffff8802235f1098 ffff8802235a07f0 000000000000000c ffffffff81e30180
Call Trace:
 [<ffffffff81807dac>] dump_stack+0x4d/0x66
 [<ffffffff8109b3ed>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8109b46c>] warn_slowpath_fmt+0x5c/0x80
 [<ffffffff814139f2>] check_for_stack+0x92/0xe0
 [<ffffffff81414000>] debug_dma_map_page+0x100/0x140
 [<ffffffff815a63e0>] usb_hcd_map_urb_for_dma+0x670/0x7a0
 [<ffffffff815a66f5>] usb_hcd_submit_urb+0x1e5/0xac0
 [<ffffffff810fcba6>] ? __lock_is_held+0x56/0x80
 [<ffffffff81137c53>] ? __module_address+0xf3/0x150
 [<ffffffff8113c1b6>] ? is_module_address+0x16/0x30
 [<ffffffff815a8242>] usb_submit_urb+0x372/0x600
 [<ffffffffa0000f7f>] usb_stor_msg_common+0xaf/0x160 [usb_storage]
 [<ffffffff8180c582>] ? wait_for_completion_interruptible_timeout+0x122/0x170
 [<ffffffffa0001372>] usb_stor_ctrl_transfer+0xa2/0xd0 [usb_storage]
 [<ffffffffa0001c37>] usb_stor_CB_transport+0x57/0x270 [usb_storage]
 [<ffffffffa0002222>] usb_stor_invoke_transport+0x282/0x5a0 [usb_storage]
 [<ffffffffa0000e6c>] usb_stor_ufi_command+0x6c/0xb0 [usb_storage]
 [<ffffffffa0003826>] usb_stor_control_thread+0x176/0x290 [usb_storage]
 [<ffffffffa00036b0>] ? fill_inquiry_response+0x20/0x20 [usb_storage]
 [<ffffffffa00036b0>] ? fill_inquiry_response+0x20/0x20 [usb_storage]
 [<ffffffff810c8d38>] kthread+0x108/0x120
 [<ffffffff810e1d68>] ? sched_clock_cpu+0x98/0xc0
 [<ffffffff810ff71d>] ? trace_hardirqs_on_caller+0x15d/0x200
 [<ffffffff810c8c30>] ? insert_kthread_work+0x80/0x80
 [<ffffffff818118fc>] ret_from_fork+0x7c/0xb0
 [<ffffffff810c8c30>] ? insert_kthread_work+0x80/0x80
Comment 16 D. Charles Pyle 2014-07-04 11:50:53 EDT
Created attachment 914744 [details]
Most recent dmesg for error

This is the dmesg output for the DMA error on the 3.16.0 series kernel.

uname output:

3.16.0-0.rc3.git2.1.fc21.x86_64 #1 SMP Wed Jul 2 13:47:38 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
Comment 17 satellitgo 2015-01-25 07:28:26 EST
seen in xfce f22 live 20150124 x86_64 on boot
Note requires setenforce 0 for networking to work
see BZ 1185195
Comment 18 satellitgo 2015-02-01 12:49:16 EST
seen in f22 workstation  live rawhide 20150201 x86_64 after install to bare metal
(BZ number referenced by Bugzilla)
kernel core 3.19.0.0.rc6.git3.1.fc22.x86_64
ABRT Server: URL=https://retrace.fedoraproject.org/faf/reports/473515/
Comment 19 satellitgo 2015-02-01 13:01:11 EST
(In reply to satellitgo from comment #18)
> seen in f22 workstation  live rawhide 20150201 x86_64 after install to bare
> metal
> (BZ number referenced by Bugzilla)
> kernel core 3.19.0.0.rc6.git3.1.fc22.x86_64
> ABRT Server: URL=https://retrace.fedoraproject.org/faf/reports/473515/

https://bugzilla.redhat.com/show_bug.cgi?id=1185195
Comment 20 Josh Boyer 2015-02-19 11:29:49 EST
The original bug was fixed.  This should be closed.  The rtsx_usb issue is tracked via another bug.
Comment 21 Josh Boyer 2015-02-19 11:30:01 EST
The original bug was fixed.  This should be closed.  The rtsx_usb issue is tracked via another bug.

Note You need to log in before you can comment on or make changes to this bug.