Bug 977561 - 'top' clears screen on exit.
'top' clears screen on exit.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: procps-ng (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 18:51 EDT by David Woodhouse
Modified: 2016-01-31 20:58 EST (History)
3 users (show)

See Also:
Fixed In Version: procps-ng-3.3.8-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-07 20:57:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2013-06-24 18:51:32 EDT
In Fedora 18, the latest output from 'top' remained on screen after you quit. This was often useful.

In Fedora 19, it gratuitously clears the screen on exit.
Comment 1 Jaromír Cápík 2013-06-25 13:26:29 EDT
Hello David.

This is caused by inevitable design changes made upstream and it isn't easily possible to return to the previous behaviour since the current behaviour is already a result of compromise. 
I understand it isn't comfortable to change your habits, but if you need to copy'n'paste the information displayed by top, then stop the refresh instead of quitting the application and then copy the content to clipboard/text editor. It may take you a while to re-learn that, but I hope you won't call us different nicknames while doing so.

I don't close bugs as WONTFIX often, but as there's only a very small chance we can achieve the previous behaviour, I don't see a reason for keeping this report open.

If you have any objections or any strong reason why the previous behaviour needs to be changed back, then let me know till friday. Otherwise I'll close the bug as WONTFIX.

Best Regards,
Jaromir.
Comment 2 David Woodhouse 2013-06-26 06:08:03 EDT
(In reply to Jaromír Cápík from comment #1)
> Hello David.
> 
> This is caused by inevitable design changes made upstream and it isn't
> easily possible to return to the previous behaviour since the current
> behaviour is already a result of compromise. 

Thanks for the coherent response. Do you have a link to mail archive or somewhere that I could familiarise myself with the previous discussion and the reasons why it was considered useful to unconditionally clear the screen, without even a config file or environment variable to modify the default behaviour?
Comment 3 Jaromír Cápík 2013-06-26 08:43:00 EDT
Hello David.

The screen clearing is an indirect result of changes in terminal manipulations which were introduced by Jim Warner (author of the 'top' tool) in order to suppress flooding the 'top' tool with SIGWINCH signals generated by some of the widely used terminal applications. It was me who reported the flooding issue and he tried to do his best in order to resolve it and released a fix for the issue in form of 8 separate commits. The commit introducing the screen clearing has the following hash : 'dedaf6e1a81738ff08ee8e8523871e12f555ad6d'. I've done a deeper analysis of the commit and it seems I was wrong with evaluation of the solution complexity. There's a good chance of making the behaviour configurable without too much effort. But I need to discuss that with Jim first.

I'll keep you posted.

Regards,
Jaromir.
Comment 4 Fedora Update System 2013-07-03 06:19:26 EDT
procps-ng-3.3.8-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/procps-ng-3.3.8-8.fc19
Comment 5 Jaromír Cápík 2013-07-03 06:28:23 EDT
Hello David.

Jim was willing to rework the solution to let the 'top' tool to keep the last listing on the screen and move the cursor to the bottom of the terminal (without any configuration changes). Please, test the 3.3.8-8.fc19 build and confirm if that resolves your issue.

Thanks.

Regards,
Jaromir.
Comment 6 David Woodhouse 2013-07-03 08:41:25 EDT
Works nicely. Thank you very much for the prompt resolution.
Comment 7 Fedora Update System 2013-07-03 21:01:41 EDT
Package procps-ng-3.3.8-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing procps-ng-3.3.8-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12292/procps-ng-3.3.8-8.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-07-07 20:57:43 EDT
procps-ng-3.3.8-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.