Bug 977564 - Ruby cart is leaving tmp/vendor
Ruby cart is leaving tmp/vendor
Status: CLOSED UPSTREAM
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Hiro Asari
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 18:56 EDT by Dan McPherson
Modified: 2015-05-14 19:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-09 09:45:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan McPherson 2013-06-24 18:56:42 EDT
Description of problem:
We hit several apps in production which were leaving tmp/vendor.

Version-Release number of selected component (if applicable):


How reproducible:
Not sure.  Need to validate we do everything we can to clean up tmp/vendor when the build is complete.  Technically we should be moving the contents from tmp/vendor and not copying so not sure why we hit this in the first place.

Actual results:
tmp/vendor exists for several gears

Expected results:
tmp/vendor shouldn't exist after the builds are complete

Additional info:
For the gears we looked at it didn't appear jenkins was involved.
Comment 2 Dan McPherson 2013-07-03 10:02:43 EDT
There may be nothing we can do.  But an example of a case that's broken:


User has used 995mb of their quota and their app size is 10mb (old app size before the latest push is 1mb let's say).  So we:

- Backup their bundles
- try to git archive their git repo contents into app-root/repo
- Fail because they don't have 10mb free
- Never get to the build step were we remove tmp/vendor

We basically need a rescue on build failures to be able to clean up tmp/vendor in this case.
Comment 3 Hiro Asari 2013-07-03 11:35:37 EDT
In this particular example, we need to agree on a signal that the failure (disk quota reached) would send, and trap that signal on the 'control' side, and perform cleanup.

This should happen on all cartridges, not just ruby.

Seems to me that this is a much bigger issue than just a simple bug.

Note You need to log in before you can comment on or make changes to this bug.