Bug 977568 - grubby fails to build for 64-bit ARM (Aarch64)
grubby fails to build for 64-bit ARM (Aarch64)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
19
arm Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 19:13 EDT by D. Marlin
Modified: 2014-05-29 15:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: grubby-8.31-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-29 15:22:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to only set RPM_OPT_FLAGS if undefined. (1.03 KB, patch)
2013-06-24 19:15 EDT, D. Marlin
no flags Details | Diff

  None (edit)
Description D. Marlin 2013-06-24 19:13:05 EDT
Description of problem:

grubby fails to build for 64-bit ARM (Aarch64) due to a compile error.

Version-Release number of selected component (if applicable):

grubby-8.26-2.fc19

How reproducible:

Consistently

Steps to Reproduce:
on an Aarch64 simulator/builder - 
1. yum downloader --source grubby
2. mock --rebuild grubby-8.26-2.fc19.src.rpm
3.

Actual results:
--------------------
+ make
gcc -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector -std=gnu99 -Wall -Werror -Wno-error=unused-function -Wno-unused-function -ggdb -DVERSION='"8.26"' -c -o grubby.o grubby.c
grubby.c:1:0: error: -fstack-protector not supported for this target [-Werror]
 /*
 ^
cc1: all warnings being treated as errors
make: *** [grubby.o] Error 1
--------------------

Expected results:

Package builds without errors.

Additional info:

RPM_OPT_FLAGS is set in the grubby Makefile, which overrides the settings in the rpm macros.  This breaks the Aarch64 build.
Comment 1 D. Marlin 2013-06-24 19:15:29 EDT
Created attachment 764811 [details]
Patch to only set RPM_OPT_FLAGS if undefined.

I verified this builds through mock on both x86_64 and aarch64.
Comment 2 D. Marlin 2014-05-29 15:22:52 EDT
Verified the current version (grubby-8.33-1.fc21) built in rawhide.

Note You need to log in before you can comment on or make changes to this bug.