Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 977585 - F18 vboxdrv verification failed, kernel tainted after mokutil --disable-validation
Summary: F18 vboxdrv verification failed, kernel tainted after mokutil --disable-valid...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 18
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-25 00:42 UTC by Gerald Cox
Modified: 2013-06-25 11:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-25 11:58:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Gerald Cox 2013-06-25 00:42:20 UTC
Description of problem:
Receiving following messages:

vboxdrv: module verification failed: signature and/or required key missing - tainting kernel
Disabling lock debugging due to kernel taint

I then disabled validation using mokutil --disable-validation, however message still occurs

Version-Release number of selected component (if applicable):
kernel-3.9.6-200

How reproducible:
Reboot


Steps to Reproduce:
1.  Reboot
2.  dmesg | grep taint
3.

Actual results:
kernel tainted 

Expected results:
kernel not tainted

Additional info:

Comment 1 Josh Boyer 2013-06-25 11:58:44 UTC
The Fedora kernel taints whenever the virtual box modules are loaded, regardless of either signature state or Secure Boot.  We don't support virtual box.


Note You need to log in before you can comment on or make changes to this bug.