Bug 977592 - svk throws perl errors while syncing and fails to update properly
svk throws perl errors while syncing and fails to update properly
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: perl-SVK (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 21:10 EDT by Derek Atkins
Modified: 2014-02-05 16:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 16:56:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Atkins 2013-06-24 21:10:39 EDT
Description of problem:

I just upgraded my laptop from F15 to F18 and now SVK throws perl errors when trying to sync and fails to complete an "update" properly.


Version-Release number of selected component (if applicable):
perl-SVK-2.2.3-9.fc18.noarch


How reproducible:

It is 100% reproducible in my case, but that's because I had an existing mirror and checkout from F15 (and earlier).  I have not tried blowing away all my data, but I shouldn't have to.


Steps to Reproduce:
1. svk sync //mirrors/gnucash        (choose your own local mirror)
2. svk update                        (from a WC checkout)
3.

Actual results:

The SYNC:

svk sync //mirrors/gnucash
Use of qw(...) as parentheses is deprecated at /usr/share/perl5/vendor_perl/SVK/Mirror.pm line 455.
Syncing svn+ssh://svn.gnucash.org/repo/gnucash
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/vendor_perl/Data/Hierarchy.pm line 215.

The Update:

svk up
Use of qw(...) as parentheses is deprecated at /usr/share/perl5/vendor_perl/SVK/Mirror.pm line 455.
Use of uninitialized value $ARGV[0] in ucfirst at /usr/share/perl5/vendor_perl/App/CLI/Command.pm line 116.
Syncing //mirrors/gnucash/branches/2.4(/mirrors/gnucash/branches/2.4) in /home/warlord/src/gnucash/gnucash-2.4/src to 20426.
    ChangeLog.2011 - skipped
    ChangeLog.2012 - skipped
g   accounts/ru/acctchrt_common.gnucash-xea
    ChangeLog - skipped
g   configure.ac
g   Makefile.am
g   NEWS
g   po/en_GB.po
g   po/nl.po
g   po/da.po
g   po/de.po
g   packaging/win32/install-impl.sh
g   packaging/win32/defaults.sh
g   packaging/win32/gnucash.iss.in
g   macros/ac_python_devel.m4
g   src/report/standard-reports/budget-flow.scm
g   src/report/standard-reports/register.scm
g   src/engine/gnc-commodity.c
g   src/import-export/import-main-matcher.c
g   doc/README-nl.win32-bin.txt
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/vendor_perl/Data/Hierarchy.pm line 215.

... And if I run it again I get the exact same output.  The first time I ran it all the g's were G's (capitals), because it did pull down the changes.  However it clearly never marked that those changes took, and isn't recognizing them.


Expected results:

No perl warnings, and an update that actually succeeds.


Additional info:

I realize I could be using git, but I have some svn packages that I've been using for a long time in SVK so I'd like to be able to continue using SVK.  Downloading into git-svn would take a long time for some of these repositories.
Comment 1 Petr Pisar 2013-06-25 02:01:41 EDT
SVK is dead (last update in 2010). I'm really sorry it does not work anymore, but I don't see any high chances in fixing it <https://rt.cpan.org/Public/Dist/Display.html?Name=SVK>.
Comment 2 Derek Atkins 2013-06-25 11:43:04 EDT
So you're saying the errors in Data/Hierarchy.pm and App/CLI/Command.pm aren't real bugs?

The issue with SVK/Mirror.pm is a simple fix to add a paren around qw:

--- SVK/Mirror.pm~	2008-12-13 01:58:21.000000000 -0500
+++ SVK/Mirror.pm	2013-06-25 11:35:42.708154255 -0400
@@ -452,7 +452,7 @@
 }
 
 for my $delegate
-    qw( find_rev_from_changeset find_changeset sync_changeset traverse_new_chan
gesets mirror_changesets get_commit_editor refresh change_rev_prop fromrev sourc
e_path relocate )
+    (qw( find_rev_from_changeset find_changeset sync_changeset traverse_new_cha
ngesets mirror_changesets get_commit_editor refresh change_rev_prop fromrev sour
ce_path relocate ))
 {
     no strict 'refs';
     *{$delegate} = sub {
Comment 3 Derek Atkins 2013-06-25 12:03:07 EDT
For the Hierarchy.pm issue, the call is coming from SVK/XD.pm, with this line at line 361:

    my @paths = $self->{checkout}->find ('', {lock => $$});

I'm not sure what the problem is here, unless perl deprecated '$$'?  This call is repeated in a couple other places within the SVK XD.pm code, e.g. line 328.


As for Command.pm, perhaps the issue is this line in SVK/Command.pm:

    local *ARGV = [$cmd, @args];

That's the only thing I can find that might somehow make $ARGV[0] undefined before it jumps into App/CLI.pm (line 179 and line 130) before finally into App/CLI/Command.pm

I'm not completely up to date on modern PERL changes, nor have I ever considered myself a perl guru, so perhaps these pointer might help with a local patch?
Comment 4 Petr Pisar 2013-06-26 02:13:35 EDT
The missing parenthesis are just simple warnings. The real problem are the other bugs. E.g. I wasn't even able to clone and import new repository into SVK.

What I say is I have no time to hunt bugs in this unmaintained crap. You are welcomed to post a patch or even better to take over maintenance in the Fedora. Obviously you are the only SVK user.
Comment 5 Petr Pisar 2013-06-26 02:16:41 EDT
Regarding $$, there was a change in Perl 5.16.0 in caching the value. It's not cached anymore across threads. So there can be bad assumptions in SVK code. See more using `perldoc perlvar'.
Comment 6 Bruno Cornec 2013-07-24 19:43:58 EDT
While not a regular Fedora user (but a RHEL one), I'd also like to see this SVK issue solved. I'm also reporting a similar issue on Mageia (which I'm using) so we could probably share our findings and fet some common patches to make it work with perl 5.16.

Our BR is at https://bugs.mageia.org/show_bug.cgi?id=10833

Sorry, I'm not a perl guru either, just using it regularly to program, so it may take some times before I can find an approriate patch as well.

Will look at other distributions to see their approach and see what we can leverage.
Comment 7 Fedora End Of Life 2013-12-21 09:07:48 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2014-02-05 16:56:59 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.