Bug 977594 - Customer can never install foreman-libvirt off of ISO because installer script removes repofile
Customer can never install foreman-libvirt off of ISO because installer scrip...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-24 21:15 EDT by Corey Welton
Modified: 2014-04-24 13:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:09:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-06-24 21:15:18 EDT
Description of problem:

Users who install from ISO will not, without workaround, be able to install foreman-libvirt package from ISO, because the installer script, after initially configuring repo file, removes it after install is completed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Download ISO and mount it.
2. Execute install_packages from iso
3. Noting that installer does not actually install foreman-libvirt, manually attempt to install it.
4. Look for repo file in /etc/yum.repos.d/ and/or examine installer script itself.

Actual results:

No package foreman-libvirt found
Observe that installer script removes repo file.

Expected results:
User can at least manually install foreman-libvirt metapackage separate from main installer.

Additional info:
Comment 3 Mike McCune 2013-06-24 21:55:54 EDT
WORKAROUND:

cd <ISO mount dir>/Packages
rpm -Uvh foreman-libvirt-*.rpm
Comment 4 Corey Welton 2013-06-25 10:10:42 EDT
foreman-libvirt has dependencies, so yum might be the better route.  That said, I still had some minor dependency issues installing foreman-libvirt, even though everything was there.  I think the recommended route is creating a localrepo, but I guess it's not /too/ hard to identify all the necessary files...

e.g.: 

yum localinstall foreman-libvirt-1.1.10014-1.noarch.rpm foreman-1.1.10014-1.noarch.rpm  foreman-compute-1.1.10014-1.noarch.rpm
Comment 6 Justin Sherrill 2013-10-15 09:30:44 EDT
I'm not even sure what the correct fix for this would be?  The solutions i can currently think of:

a) Install foreman-libvirt as part of katello-foreman-all
b) Assume the user will leave the ISO mounted, and leave the repo file in place.
c) have some script that will install a package from the iso (i.e.  ./iso-install foreman-libvirt)

Thoughts?
Comment 7 Dominic Cleal 2013-10-15 10:26:28 EDT
We could do (2), but leave the repo disabled by default so it doesn't interfere when the ISO's removed?  Users could then do "yum --enablerepo=satellite6 install foreman-libvirt".

The other thing to consider is that we plan on having better support in the installer for plugins etc, so it might also be possible to re-run a part of the installer, which could re-enable the repo.

I dislike (1) because there are a number of pieces of optional functionality.  Always installing them on non-ISO installs via katello-foreman-all I think is over the top and will add many more packages.
Comment 8 Justin Sherrill 2013-10-15 11:01:46 EDT
yeah, agree on you 100% with a).  Leaving the repo file there but disabled is not a bad idea, i wonder what the likelihood of the user mounting it to a different location is though
Comment 9 Mike McCune 2013-10-16 17:09:40 EDT
instead of mounting why don't we just copy the repo to something like /var/satellite/installer-repo and reference that instead of mounted directly.  The repo isn't *that* big is it?
Comment 10 Justin Sherrill 2013-10-23 11:20:12 EDT
https://github.com/Katello/katello-misc/pull/20

chose /opt/satellite as the destination, since these files are not tracked by the package manager
Comment 13 Og Maciel 2013-10-25 15:21:21 EDT
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-20.el6sat.noarch
* foreman-postgresql-1.3.0-20.el6sat.noarch
* katello-1.4.6-49.el6sat.noarch
* katello-all-1.4.6-49.el6sat.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-27.el6sat.noarch
* katello-cli-common-1.4.3-27.el6sat.noarch
* katello-common-1.4.6-49.el6sat.noarch
* katello-configure-1.4.7-7.el6sat.noarch
* katello-configure-foreman-1.4.7-7.el6sat.noarch
* katello-foreman-all-1.4.6-49.el6sat.noarch
* katello-glue-candlepin-1.4.6-49.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-49.el6sat.noarch
* katello-glue-pulp-1.4.6-49.el6sat.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.24.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.24.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.24.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.24.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.24.beta.el6sat.noarch
* pulp-server-2.3.0-0.24.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.23-2.el6sat.noarch
* signo-katello-0.0.23-2.el6sat.noarch
Comment 14 Bryan Kearney 2014-04-24 13:09:27 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 15 Bryan Kearney 2014-04-24 13:10:57 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.