Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 977618 - left and right arrow keys do not move user between tabs--no way to reach "tunables" tab
Summary: left and right arrow keys do not move user between tabs--no way to reach "tun...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: powertop
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-25 02:16 UTC by John Poelstra
Modified: 2013-06-25 13:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-25 09:04:40 UTC
Type: Bug


Attachments (Terms of Use)

Description John Poelstra 2013-06-25 02:16:18 UTC
Description of problem:

left and right arrow keys do not move user between tabs--no way to reach "tunables" tab, thus making this program worthless for increasing battery life.

Version-Release number of selected component (if applicable):

powertop-2.3-1.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. run powertop
2. attempt to move between tabs with arrow keys

Comment 1 John Poelstra 2013-06-25 03:06:56 UTC
Another data point.. installing an older version from Fedora 18 exhibits the same behavior on Fedora 19

http://mirrors.kernel.org/fedora/releases/18/Everything/x86_64/os/Packages/p/powertop-2.2-3.fc18.x86_64.rpm

Comment 2 John Poelstra 2013-06-25 04:31:00 UTC
I can confirm that powertop-2.1-2.fc17.x86_64.rpm DOES work correctly on Fedora 19 in that the tabs are accessible with the arrow keys.

Comment 3 Jaroslav Škarvada 2013-06-25 09:04:40 UTC
This is by design. Arrow keys allow you to scroll up and down through the screen. For switching through the tabs use Tab and Shift + Tab.

Comment 4 John Poelstra 2013-06-25 13:42:56 UTC
(In reply to Jaroslav Škarvada from comment #3)
> This is by design. Arrow keys allow you to scroll up and down through the
> screen. For switching through the tabs use Tab and Shift + Tab.

Where "by design" == "change in UX behavior from previous versions" :)


Note You need to log in before you can comment on or make changes to this bug.