Bug 977652 - ghc fails to compile files using llvm-3.3 on ARM
ghc fails to compile files using llvm-3.3 on ARM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghc (Show other bugs)
19
arm Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-06-25 01:30 EDT by Jens Petersen
Modified: 2013-07-04 22:05 EDT (History)
5 users (show)

See Also:
Fixed In Version: ghc-7.4.2-11.1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-04 22:05:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2013-06-25 01:30:14 EDT
Description of problem:
ghc < 7.8 (unreleased) seems not to support llvm > 3.2.

Version-Release number of selected component (if applicable):
ghc-7.4.2
llvm-3.3-rc

How reproducible:
100%

Steps to Reproduce:
1. try to build a haskell package on F19 ARM with llvm-3.3pre

Actual results:
+ ghc --make -no-user-package-conf Setup
[1 of 1] Compiling Main             ( Setup.hs, Setup.o )
wrong initalizer for intrinsic global variable
[0 x i8*] undef
Broken module found, compilation aborted!
0  libLLVM-3.3.so 0xb5e4f4f8 llvm::sys::PrintStackTrace(_IO_FILE*) + 36
1  libLLVM-3.3.so 0xb5e4f2d8
2  libc.so.6      0xb595ec60 __default_sa_restorer_v2 + 0
3  libc.so.6      0xb595d854 gsignal + 52
4  libc.so.6      0xb595ee54 abort + 408
5  libLLVM-3.3.so 0xb649580c
6  libLLVM-3.3.so 0xb649c4f4
7  libLLVM-3.3.so 0xb647828c llvm::FPPassManager::doFinalization(llvm::Module&) + 80
8  libLLVM-3.3.so 0xb647f1b4 llvm::MPPassManager::runOnModule(llvm::Module&) + 640
9  libLLVM-3.3.so 0xb647f2f0 llvm::PassManagerImpl::run(llvm::Module&) + 152
10 opt            0x0001830c main + 2532
11 libc.so.6      0xb594728c __libc_start_main + 276
Stack dump:
0.	Program arguments: opt /tmp/ghc2007_0/ghc2007_0.ll -o /tmp/ghc2007_0/ghc2007_0.bc -mem2reg 
llc: /tmp/ghc2007_0/ghc2007_0.bc: error: Could not open input file: No such file or directory

Expected results:
No error

Additional info:
http://hackage.haskell.org/trac/ghc/ticket/7996
There seems to be a fix for this for ghc-7.8 (commit db9b63105a54),
which we can try test and backport.
Comment 1 Jens Petersen 2013-06-25 06:02:18 EDT
Hopefully fixed in ghc-7.4.2-11.1.fc19.

That's the good news - the bad news is I don't think
this will build on ARM without rebootstrapping ghc probably. :-(

I assume there is a good reason for shipping llvm-3.3-rc in f19-final...
Comment 2 Peter Robinson 2013-06-25 06:11:10 EDT
> I assume there is a good reason for shipping llvm-3.3-rc in f19-final...

Mesa 3.2 requirement for newer graphics card and feature support like video offload. There was a heads up mail send to devel quite some time ago
Comment 3 Fedora Update System 2013-06-25 23:05:57 EDT
ghc-7.4.2-11.1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ghc-7.4.2-11.1.fc19
Comment 4 Fedora Update System 2013-06-26 13:07:52 EDT
Package ghc-7.4.2-11.1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ghc-7.4.2-11.1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11712/ghc-7.4.2-11.1.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-07-04 22:05:44 EDT
ghc-7.4.2-11.1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.