This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 97767 - nfs starts before cups --> nfs sometimes binds cups IPP port
nfs starts before cups --> nfs sometimes binds cups IPP port
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
http://www.linuxprinting.org/foomatic...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-20 13:24 EDT by dominik schnitzer
Modified: 2007-04-18 12:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1.19-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-23 11:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dominik schnitzer 2003-06-20 13:24:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030527
Debian/1.3.1-2

Description of problem:
NFS is started before the cups daemon:
- the nfs components randomly select a free port < 1024 and _sometimes_ select
the cups IPP port.

Which means --> cups cannot start, because the IPP Port is in use and exits with:
--snip--
cupsd: Child exited with status 98!?
--snip--


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. reboot until ;-) lockd for example runs on cups IPP port
2. cups will not start, since tcp/663 is already bound
    

Additional info:

Read: http://www.linuxprinting.org/foomatic2.9/cups-faq.html#q_4_2
Comment 1 Tim Waugh 2003-06-23 11:46:56 EDT
Thanks.  Fixed package is cups-1.1.19-8.
Comment 2 Tim Waugh 2003-06-24 12:28:37 EDT
*** Bug 97958 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.